mbox series

[bug#69343,v3,00/12] Simplify bootloader data structures and procedures

Message ID cover.1722741214.git.lilah@lunabee.space
Headers show
Series Simplify bootloader data structures and procedures | expand

Message

Lilah Tascheter Aug. 4, 2024, 3:13 a.m. UTC
Two small changes here: add gnu/system/boot.scm to gnu/local.mk, and one other
small fix. Kinda forgot what that second fix was, sorry.

Felix Lechner (12):
  Fix bug where the extra menu entries for a bootloader were shown
    twice.
  Move <boot-parameters> record to a separate file.
  Also move boot-parameters->menu-entry.
  Rename seconds->string procedure to epoch->date-string.
  Move epoch->date-string to gnu/system/boot.scm and use it elsewhere.
  Offer a uniform decorated-boot-label and use it.
  Rename boot-parameters to boot-alternatives when appropriate.
  Rename two remote variables confusingly named 'generations'.
  Give a separate name to a commonly used expression.
  Simplify profile->boot-alternatives.
  Split generation->boot-parameters out of profile->boot-alternatives.
  Encapsulate <boot-parameters> to retain generation, system-path and
    epoch.

 gnu/local.mk              |   1 +
 gnu/machine/ssh.scm       |  77 ++++----
 gnu/system.scm            | 287 +----------------------------
 gnu/system/boot.scm       | 376 ++++++++++++++++++++++++++++++++++++++
 guix/scripts/system.scm   |  71 +++----
 tests/boot-parameters.scm |   1 +
 6 files changed, 453 insertions(+), 360 deletions(-)
 create mode 100644 gnu/system/boot.scm


base-commit: f59c4126827af3d2041d49f1d0a8ce12b41470cf

Comments

Herman Rimm Sept. 5, 2024, 7:13 a.m. UTC | #1
Hello Lilah,

Booting with the EFI boot stub still works when using this patch series.

Can you squash patch #3 into #2 and try to keep the lines within 78
columns in patches #6, #8, #9, #10 and #12?  Also in #12, can you align
all the boot-alternative-* and indicate the type of
boot-alternative-parameters?

Cheers,
Herman