mbox series

[bug#70924,00/10] Add some SageMath standard packages.

Message ID cover.1715632275.git.monego@posteo.net
Headers show
Series Add some SageMath standard packages. | expand

Message

Vinicius Monego May 13, 2024, 8:50 p.m. UTC
I was looking at https://doc.sagemath.org/html/en/reference/spkg/ and made a list of the missing packages. There are around 45 packages missing in the Standard Packages, and 77 in the Optional Packages.

I will submit what can be packaged in various patch series of 10 packages to ease the review. Some of the packages can't be included because they depend on recent versions of core packages (python-referencing apparently needs a newer version of hatchling).

Some of these have been packaged in https://issues.guix.gnu.org/56729 while others are new.

Vinicius Monego (10):
  gnu: Add python-memory-allocator.
  gnu: Add python-calver.
  gnu: Add python-async-lru.
  gnu: Add python-isoduration.
  gnu: Add python-uri-template.
  gnu: Add python-pyproject-api.
  gnu: Add primecount.
  gnu: Add python-primecountpy.
  gnu: Add python-types-dateutil.
  gnu: Add python-pplpy.

 gnu/packages/maths.scm      |  47 ++++++++++++
 gnu/packages/python-xyz.scm | 143 ++++++++++++++++++++++++++++++++++++
 gnu/packages/sagemath.scm   |  52 +++++++++++++
 3 files changed, 242 insertions(+)


base-commit: 89cd778f6a45cd9b43a4dc1f236dcd0a87af955c

Comments

Vinicius Monego May 14, 2024, 3:11 p.m. UTC | #1
Em 13/05/2024 17:50, Vinicius Monego escreveu:
> I was looking at https://doc.sagemath.org/html/en/reference/spkg/ and made a list of the missing packages. There are around 45 packages missing in the Standard Packages, and 77 in the Optional Packages.
>
> I will submit what can be packaged in various patch series of 10 packages to ease the review. Some of the packages can't be included because they depend on recent versions of core packages (python-referencing apparently needs a newer version of hatchling).
>
> Some of these have been packaged in https://issues.guix.gnu.org/56729 while others are new.
>
> Vinicius Monego (10):
>    gnu: Add python-memory-allocator.
>    gnu: Add python-calver.
>    gnu: Add python-async-lru.
>    gnu: Add python-isoduration.
>    gnu: Add python-uri-template.
>    gnu: Add python-pyproject-api.
>    gnu: Add primecount.
>    gnu: Add python-primecountpy.
>    gnu: Add python-types-dateutil.
>    gnu: Add python-pplpy.
>
>   gnu/packages/maths.scm      |  47 ++++++++++++
>   gnu/packages/python-xyz.scm | 143 ++++++++++++++++++++++++++++++++++++
>   gnu/packages/sagemath.scm   |  52 +++++++++++++
>   3 files changed, 242 insertions(+)
>
>
> base-commit: 89cd778f6a45cd9b43a4dc1f236dcd0a87af955c
I just saw that python-isoduration and python-uri-template are in the 
python-team branch already, and also a few other standard packages not 
in this series.
Sharlatan Hellseher Oct. 24, 2024, 10:07 a.m. UTC | #2
Hi,

I've checked and build 8 of 10 patches successfully; applied them with
minor modifications.

- add to master [8/8]
  - [X] [PATCH 01/10] gnu: Add python-memory-allocator.
    - Add python-setuptools
    - Adjust indentation
  - [X] [PATCH 02/10] gnu: Add python-calver.
    - Add python-setuptools
    - Adjust indentation
  - [X] [PATCH 03/10] gnu: Add python-async-lru.
    - Add python-setuptools
    - Adjust indentation
  - [X] [PATCH 06/10] gnu: Add python-pyproject-api.
  - [X] [PATCH 07/10] gnu: Add primecount.
    - Update to the latest version in additional commit
    - Link to existing primesiev package
  - [X] [PATCH 08/10] gnu: Add python-primecountpy.
    - Link to existing primesiev package
  - [X] [PATCH 09/10] gnu: Add python-types-dateutil.
    - Add python-setuptools
  - [X] [PATCH 10/10] gnu: Add python-pplpy.
    - Add missing maths module

- in python-team [2/2]
  - [X] [PATCH 05/10] gnu: Add python-uri-template.
        529fe93b14fee0073c2cbb66909bfcd1f16024ab
        Author:     Ricardo Wurmus <rekado@elephly.net>
        AuthorDate: Tue May 7 20:17:57 2024 +0200
        Commit:     Sharlatan Hellseher <sharlatanus@gmail.com>
        CommitDate: Mon Oct 21 23:19:30 2024 +0100
  - [X] [PATCH 04/10] gnu: Add python-isoduration.
        f06fc8e2089ee3eb0a85f4d28de0e1a5dd955eb5
        Author:     Ricardo Wurmus <rekado@elephly.net>
        AuthorDate: Tue May 7 21:26:52 2024 +0200
        Commit:     Sharlatan Hellseher <sharlatanus@gmail.com>
        CommitDate: Mon Oct 21 23:19:30 2024 +0100

Built successfully on x86_64:
--8<---------------cut here---------------start------------->8---
/gnu/store/wn24b3v2kbv7q5msivrfjz6qbgx43fhg-python-pplpy-0.8.10
/gnu/store/4cigz1384hrxwhgdhzx2z1ycm210g739-python-types-dateutil-2.9.0.20240316
/gnu/store/8kr52bq6mrkf3g4rn03n34pip5xjm9f6-python-primecountpy-0.1.0
/gnu/store/a7m2rdisfqvs4avh4sah63xdnvwxj4l6-primecount-7.14
/gnu/store/47wsy1rv1m0ci0b6jq6v2i230jjipkiq-python-pyproject-api-1.6.1
/gnu/store/nzwbfz2ww4qwssngr5kdwiz8wy1cgbjd-python-async-lru-2.0.4
/gnu/store/pkcdjfvvhnwnrfjkg64dsqd4sav3p16j-python-calver-2022.06.26
/gnu/store/j7wakqm3lhdfxp0m516q57lk7k6cbmnw-python-memory-allocator-0.1.4
--8<---------------cut here---------------end--------------->8---

- 06696ac708 * gnu: Add python-types-dateutil.
- f3cfd885f1 * gnu: Add python-pyproject-api.
- a47a1ff036 * gnu: Add python-memory-allocator.
- 116a6c78f1 * gnu: Add python-async-lru.
- 15033a1e63 * gnu: Add python-pplpy.
- add8d159e8 * gnu: Add python-calver.
- 9d577f0f4c * gnu: Add python-primecountpy.
- 64ed498737 * gnu: primecount: Update to 7.14.
- 6c72e72ae8 * gnu: Add primecount.

--
Thanks,
Oleg