mbox series

[bug#70892,0/6] Add visionfive2 support.

Message ID cover.1715508730.git.zhengjunjie@iscas.ac.cn
Headers show
Series Add visionfive2 support. | expand

Message

Zheng Junjie May 12, 2024, 11 a.m. UTC
hello!, this patchset add support for visionfive2.
for now, must boot from spl's uboot and set fdtfile to starfive/jh7110-starfive-visionfive-2-v1.3b.dtb

uboot> setenv fdtfile starfive/jh7110-starfive-visionfive-2-v1.3b.dtb
uboot> savenv

Zheng Junjie (6):
  gnu: linux-libre-6.8: add riscv config.
  image: raise error when use both grub-efi* bootloader and not gpt
    image.
  gnu: shepherd-0.10: When target riscv64, use guile-fibers-1.1.
  gnu: Add u-boot-starfive-visionfive2.
  bootloader: Add u-boot-starfive-visionfive2-bootloader.
  system: images: Add visionfive2 module.

 Makefile.am                                   |    1 +
 gnu/bootloader/u-boot.scm                     |   17 +
 gnu/local.mk                                  |    1 +
 gnu/packages/admin.scm                        |    5 +-
 .../aux-files/linux-libre/6.8-riscv.conf      | 7681 +++++++++++++++++
 gnu/packages/bootloaders.scm                  |   31 +
 gnu/system/image.scm                          |    6 +-
 gnu/system/images/visionfive2.scm             |  121 +
 8 files changed, 7858 insertions(+), 5 deletions(-)
 create mode 100644 gnu/packages/aux-files/linux-libre/6.8-riscv.conf
 create mode 100644 gnu/system/images/visionfive2.scm


base-commit: 56980ea500a1db3c8586972b8abfaf5c4e24f82d

Comments

Vagrant Cascadian May 15, 2024, 6:02 p.m. UTC | #1
On 2024-05-12, Zheng Junjie wrote:
> hello!, this patchset add support for visionfive2.
> for now, must boot from spl's uboot and set fdtfile to starfive/jh7110-starfive-visionfive-2-v1.3b.dtb
>
> uboot> setenv fdtfile starfive/jh7110-starfive-visionfive-2-v1.3b.dtb
> uboot> savenv

Are there patches submitted to upstream u-boot to fix this? Are they
present in newer versions? If so, I think it would be worth backporting
those patches until a newer u-boot version is merged into guix...

Having it only half-work is kind of silly :)

live well,
  vagrant