mbox series

[bug#70351,0/3] gnu: cross-gcc: Support GCC 13.

Message ID cover.1712918802.git.jean@foundation.xyz
Headers show
Series gnu: cross-gcc: Support GCC 13. | expand

Message

Jean-Pierre De Jesus Diaz April 12, 2024, 10:49 a.m. UTC
*** BLURB HERE ***

Jean-Pierre De Jesus DIAZ (3):
  gnu: cross-gcc-patches: Avoid patch for GCC 13+.
  gnu: cross-gcc: Add patch for GCC 13.
  gnu: Add gcc-cross-x86_64-w64-mingw32-toolchain-13.

 gnu/local.mk                                  |  1 +
 gnu/packages/cross-base.scm                   |  8 ++++-
 gnu/packages/cross-toolchain.scm              |  5 +++
 .../gcc-13-cross-system-header-dir.patch      | 32 +++++++++++++++++++
 4 files changed, 45 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/gcc-13-cross-system-header-dir.patch


base-commit: 4e7337536ba41e888a601c92fada8a4adca9d2c6

Comments

Jean-Pierre De Jesus Diaz April 12, 2024, 10:52 a.m. UTC | #1
This patch series fixes the build of cross compilers for GCC 13,
first a patch was avoided for GCC 13 as it is not needed anymore
and a patch was added to fix compilation as in GCC 13 the way
that --includedir and --with-native-system-header-dir changed
the way it works and assumed that --includedir is where the
system headers are installed.

This fixes the issue: <https://issues.guix.gnu.org/69913>.

(Sent again the cover letter since I forgot to :w it seems).

Jean-Pierre De Jesus DIAZ (3):
  gnu: cross-gcc-patches: Avoid patch for GCC 13+.
  gnu: cross-gcc: Add patch for GCC 13.
  gnu: Add gcc-cross-x86_64-w64-mingw32-toolchain-13.

 gnu/local.mk                                  |  1 +
 gnu/packages/cross-base.scm                   |  8 ++++-
 gnu/packages/cross-toolchain.scm              |  5 +++
 .../gcc-13-cross-system-header-dir.patch      | 32 +++++++++++++++++++
 4 files changed, 45 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/gcc-13-cross-system-header-dir.patch


base-commit: 4e7337536ba41e888a601c92fada8a4adca9d2c6
Jean-Pierre De Jesus Diaz April 12, 2024, 11:22 a.m. UTC | #2
This patch series fixes the build of cross compilers for GCC 13,
first a patch was avoided for GCC 13 as it is not needed anymore
and a patch was added to fix compilation as in GCC 13 the way
that --includedir and --with-native-system-header-dir changed
the way it works and assumed that --includedir is where the
system headers are installed.

This fixes the issue: <https://issues.guix.gnu.org/69913>.

(Sent again the cover letter since I forgot to :w it seems).

On Fri, Apr 12, 2024 at 10:49 AM Jean-Pierre De Jesus DIAZ
<jean@foundation.xyz> wrote:
>
> *** BLURB HERE ***
>
> Jean-Pierre De Jesus DIAZ (3):
>   gnu: cross-gcc-patches: Avoid patch for GCC 13+.
>   gnu: cross-gcc: Add patch for GCC 13.
>   gnu: Add gcc-cross-x86_64-w64-mingw32-toolchain-13.
>
>  gnu/local.mk                                  |  1 +
>  gnu/packages/cross-base.scm                   |  8 ++++-
>  gnu/packages/cross-toolchain.scm              |  5 +++
>  .../gcc-13-cross-system-header-dir.patch      | 32 +++++++++++++++++++
>  4 files changed, 45 insertions(+), 1 deletion(-)
>  create mode 100644 gnu/packages/patches/gcc-13-cross-system-header-dir.patch
>
>
> base-commit: 4e7337536ba41e888a601c92fada8a4adca9d2c6
> --
> 2.41.0
>
Christopher Baines April 15, 2024, 9:41 a.m. UTC | #3
Jean-Pierre De Jesus DIAZ <jean@foundation.xyz> writes:

> This patch series fixes the build of cross compilers for GCC 13,
> first a patch was avoided for GCC 13 as it is not needed anymore
> and a patch was added to fix compilation as in GCC 13 the way
> that --includedir and --with-native-system-header-dir changed
> the way it works and assumed that --includedir is where the
> system headers are installed.
>
> This fixes the issue: <https://issues.guix.gnu.org/69913>.
>
> (Sent again the cover letter since I forgot to :w it seems).
>
> Jean-Pierre De Jesus DIAZ (3):
>   gnu: cross-gcc-patches: Avoid patch for GCC 13+.
>   gnu: cross-gcc: Add patch for GCC 13.
>   gnu: Add gcc-cross-x86_64-w64-mingw32-toolchain-13.

Looks good to me, I've pushed these patches to master as
4e7c3867ad30d4be761666fe311de90b7b4bd5f9.

Chris