mbox series

[bug#69940,0/2] Making a 'guix' package with specific channels

Message ID cover.1711115625.git.ludo@gnu.org
Headers show
Series Making a 'guix' package with specific channels | expand

Message

Ludovic Courtès March 22, 2024, 1:58 p.m. UTC
From: Ludovic Courtès <ludovic.courtes@inria.fr>

Hello Guix!

This patch series aims to allow users to create an operating system
that runs a specific Guix for ‘guix-service-type’, and in particular
for /run/current-system/profile/bin/guix: it could be the ‘guix’
channel pinned to a specific revision, or it could be ‘guix’ together
with additional channels.  Here’s the example added in the new
section of the manual:

     (use-modules (guix channels))

     (define my-channels
       ;; Channels that should be available to
       ;; /run/current-system/profile/bin/guix.
       (append
        (list (channel
               (name 'guix-science)
               (url "https://github.com/guix-science/guix-science")
               (branch "master")))
        %default-channels))

     (operating-system
       ;; ...
       (services
         ;; Change the package used by 'guix-service-type'.
         (modify-services %base-services
           (guix-service-type
            config => (guix-configuration
                       (inherit config)
                       (channels my-channels)
                       (guix (guix-for-channels my-channels)))))))

The resulting operating system will have both the ‘guix’ and the
‘guix-science’ channels visible by default.  The ‘channels’ field of
‘guix-configuration’ above ensures that /etc/guix/channels.scm specifies
the same set of channels

Thoughts?

Thanks,
Ludo’.

Ludovic Courtès (2):
  build-system/channel: Add support for additional channels.
  gnu: guix: Define ‘guix-for-channels’ and document its use.

 doc/guix.texi                       | 67 ++++++++++++++++++++++++++++-
 gnu/packages/package-management.scm | 14 +++++-
 guix/build-system/channel.scm       |  7 ++-
 3 files changed, 83 insertions(+), 5 deletions(-)


base-commit: 40f53e8fb5b867e3a1e8fa798328423718282aac

Comments

Ludovic Courtès April 5, 2024, 4:30 p.m. UTC | #1
Hello,

Ludovic Courtès <ludo@gnu.org> skribis:

>   build-system/channel: Add support for additional channels.
>   gnu: guix: Define ‘guix-for-channels’ and document its use.

Pushed as be14d41d9be3ef91d11ab24780855682c432cac9.

Ludo’.