mbox series

[bug#69904,00/10] gnu: Add cl-ciel.

Message ID cover.1710883390.git.sharlatanus@gmail.com
Headers show
Series gnu: Add cl-ciel. | expand

Message

Sharlatan Hellseher March 19, 2024, 9:34 p.m. UTC
Hi Guix,

It's been a long time since I packed some Common Lisp! Here we go - welcome
CIEL as stated on the project's README - an Extended Lisp. Scripting with
batteries included.

This series includes just CL library and does not provide ready-to-use image or
binary as it's mentioned in Makefile, which may be prepared as dedicated
package if we may need it (see pgloader):

--8<---------------cut here---------------start------------->8---
image:
	$(LISP) --load build-image.lisp

build:
	$(LISP) --non-interactive \
		--eval '(ql:quickload :deploy)' \
		--eval '(ql:quickload "cl+ssl")' \
		--load ciel.asd \
		--load build-config.lisp \
		--eval '(ql:quickload :swank)' \
	     --eval '(push :deploy-console *features*)' \
	     --eval '(ql:quickload :ciel)' \
	     --eval '(ql:quickload :ciel/repl)' \
	     --eval '(asdf:make :ciel/repl)' \
	     --eval '(quit)'
--8<---------------cut here---------------end--------------->8---

Build and lint are passed locally, but I've got issue to fix ecl-boost-json
(check comments for details) leaving it for Guillaume ;-) or for the next
update cycle to check.

Thanks,
Oleg

Sharlatan Hellseher (10):
  gnu: Add cl-arrow-macros.
  gnu: Add cl-trivial-utilities.
  gnu: Add cl-trivial-monitored-thread.
  gnu: Add cl-boost-json.
  gnu: Add cl-st-json.
  gnu: Add cl-json-pointer.
  gnu: Add cl-easy-routes.
  gnu: Add cl-vgplot.
  gnu: Add cl-punch.
  gnu: Add cl-ciel.

 gnu/packages/lisp-xyz.scm | 396 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 396 insertions(+)


base-commit: b7eb1a8116b2caee7acf26fb963ae998fbdb4253

Comments

Guillaume Le Vaillant March 20, 2024, 1:29 p.m. UTC | #1
Hi Sharlatan.
I made a quick review of this patch series and replied to some of the
patch emails with some things to fix. The rest looked good to me (but
I have not tried to run everything).
If after the few fixes everything still works fine on your side, no need
to send a v2 for review, just push the updated patches.
Sharlatan Hellseher March 21, 2024, 10:01 p.m. UTC | #2
Hi Guillaume,

Thanks for the review!

I've covered all of review comments and added 2 more trivial packages from
already know upstreams: CL-HUNCHENTOOT-ERRORS and CL-MIMEPARSE to have
all systems from CL-EASY-ROUTES availale.

Pushed as 14942e2abb..c75eb3b38a to master.

--
Oleg