mbox series

[bug#67512,v4,0/4] Add LibreWolf

Message ID cover.1707855137.git.ian@retrospec.tv
Headers show
Series Add LibreWolf | expand

Message

Ian Eure Feb. 13, 2024, 8:34 p.m. UTC
During testing, I found some problems with v3 of the patch.

* The vendor-provided browser config was getting clobbered during 'autoconfig.  Reworked this to append to librewolf.cfg instead of obliterating it or using autoconfig.js.
* Extension search from about:addons was broken, because extensions.getAddons.search.browseURL was missing the %TERMS% placeholder.  Added.
* extensions.getAddons settings were defined with pref() instead of defaultPref().  pref() is for user settings, and causes them to show up as modified in about:config, with a revert button to restore the value from defaultPref (which is Mozilla's addons repo).  Switched to defaultPref().

Both the extension search and pref/defaultPref issues are present in torbrowser and mullvad, and *if* those upstreams ship autoconfig.js files, their contents won't make it into the Guix packages.  Someone might want to look into those issues.

Ian Eure (4):
  gnu: Move icu4c-73 from gnuzilla to icu4c.
  gnu: nss: Update to 3.97.
  gnu: Add wasm packages.
  gnu: Add librewolf.

 gnu/packages/certs.scm        |   4 +-
 gnu/packages/gnuzilla.scm     |  27 +-
 gnu/packages/icu4c.scm        |  22 ++
 gnu/packages/librewolf.scm    | 642 ++++++++++++++++++++++++++++++++++
 gnu/packages/nss.scm          |   6 +-
 gnu/packages/tor-browsers.scm |   3 +-
 gnu/packages/wasm.scm         | 273 +++++++++++++++
 7 files changed, 945 insertions(+), 32 deletions(-)
 create mode 100644 gnu/packages/librewolf.scm
 create mode 100644 gnu/packages/wasm.scm


base-commit: b6439fc5f800b5d22d48192bc347be794f050329