mbox series

[bug#67969,0/4] guix: scons: Support cross-compilation.

Message ID cover.1703248242.git.jean@foundationdevices.com
Headers show
Series guix: scons: Support cross-compilation. | expand

Message

Jean-Pierre De Jesus DIAZ Dec. 22, 2023, 12:36 p.m. UTC
This removes the need to use `(gnu packages cross-base)' in
the `make-nsis' procedure at `(gnu packages installers)' by
making use of the `#:target' keyword argument.

As a result scons-build-system now supports cross-compilation,
although it is not very useful for general cross-compilation
as SCons doesn't have a standard way of setting the "target"
and each SConscript specifies which toolchain to use
manually, so it depends on a per package basis on how to
select the correct target as projects will generally take
some command line variables for that, like in the `make-nsis'
case.

Jean-Pierre De Jesus DIAZ (4):
  guix: scons-build: Cleanup keyword arguments.
  guix: scons: Support cross-compilation.
  gnu: make-nsis: Use cross-compilation.
  gnu: make-nsis: Adjust description acronym.

 gnu/packages/installers.scm | 129 +++++++++++-------------------------
 guix/build-system/scons.scm | 110 +++++++++++++++++++++++++-----
 2 files changed, 132 insertions(+), 107 deletions(-)


base-commit: ca813173894360edef35a5d98878a3135e99e62a

Comments

Jean-Pierre De Jesus DIAZ Dec. 22, 2023, 2:43 p.m. UTC | #1
Hello,

Sorry for the noise but I've realised this is not the correct
solution as the nsis compiler is indeed a Linux binary and
only code needed for Windows is cross-compiled to
mingw32.

So it makes sense to have the cross toolchain as an input
instead of using target.
Jean-Pierre De Jesus DIAZ Dec. 22, 2023, 2:44 p.m. UTC | #2
close 67969

On Fri, Dec 22, 2023 at 2:43 PM Jean-Pierre De Jesus Diaz
<jean@foundationdevices.com> wrote:
>
> Hello,
>
> Sorry for the noise but I've realised this is not the correct
> solution as the nsis compiler is indeed a Linux binary and
> only code needed for Windows is cross-compiled to
> mingw32.
>
> So it makes sense to have the cross toolchain as an input
> instead of using target.
>
> --
> Jean-Pierre De Jesus DIAZ
> Foundation Devices, Inc.