mbox series

[bug#67564,0/3] Fixes for haskell importers

Message ID cover.1701421819.git.saku@laesvuori.fi
Headers show
Series Fixes for haskell importers | expand

Message

Saku Laesvuori Dec. 1, 2023, 9:24 a.m. UTC
The first two patches fix crashes in the hackage[1] and stackage
importers.

The third patch improves the cabal file parser so that it can parse a
larger subset of valid cabal files[2]. It fixes guix refresh for 7
packages in Guix.

[1]: https://issues.guix.gnu.org/64734
[2]: https://issues.guix.gnu.org/35743

Saku Laesvuori (3):
  guix: import: hackage: Fix crash on recursive import
  guix: import: stackage: Fix crash on recursive import
  guix: import: Parse cabal layout blocks correctly

 guix/import/cabal.scm    | 42 ++++++++++++++++++----------------------
 guix/import/hackage.scm  |  2 +-
 guix/import/stackage.scm |  2 +-
 3 files changed, 21 insertions(+), 25 deletions(-)


base-commit: cd46757c1a0f886848fbb6828c028dd2a2532767

Comments

Lars-Dominik Braun Dec. 1, 2023, 3:06 p.m. UTC | #1
Hi,

> The third patch improves the cabal file parser so that it can parse a
> larger subset of valid cabal files[2]. It fixes guix refresh for 7
> packages in Guix.

which seven packages in Guix are affected? Could you also adapt the
testcases in tests/hackage.scm and add new ones checking the expected
behavior?

Thanks,
Lars
Saku Laesvuori Dec. 2, 2023, 5:27 p.m. UTC | #2
> > The third patch improves the cabal file parser so that it can parse a
> > larger subset of valid cabal files[2]. It fixes guix refresh for 7
> > packages in Guix.
> 
> which seven packages in Guix are affected?

- ghc-conduit
- ghc-warp
- ghc-wai-logger
- ghc-streaming-commons
- ghc-persistent-test
- ghc-language-c
- ghc-hasktags

> Could you also adapt the testcases in tests/hackage.scm and add new
> ones checking the expected behavior?

Done in v2. There was already a test for this that was expected to fail.
I just marked it to be expected to pass instead.

- Saku
Lars-Dominik Braun Dec. 3, 2023, 8:13 a.m. UTC | #3
Hi,

> Done in v2. There was already a test for this that was expected to fail.
> I just marked it to be expected to pass instead.

yes, you’re right. Merged as:

5bd00bb54235856dddd11e9f0d03481c5469ca63 guix: import: Parse cabal layout blocks correctly
acef524961d4da3464dbc392699fbe7deb0a467b guix: import: stackage: Fix crash on recursive import
160385c013b0403af427b61b1d1cc9a75bc3315d guix: import: hackage: Fix crash on recursive import

Thanks you very much!
Lars