mbox series

[bug#67120,0/4] Add jellyfin-mpv-player and deps

Message ID cover.1699762188.git.ian@retrospec.tv
Headers show
Series Add jellyfin-mpv-player and deps | expand

Message

Ian Eure Nov. 12, 2023, 4:13 a.m. UTC
This patchset adds jellyfin-mpv-shim and a handful of Python dependencies it needs.

Ian Eure (4):
  gnu: Add python-mpv-jsonipc.
  gnu: Add python-jellyfin-apiclient.
  gnu: Add python-pystray.
  gnu: Add jellyfin-mpv-shim.

 gnu/packages/python-xyz.scm | 61 +++++++++++++++++++++++++++++++++++++
 gnu/packages/video.scm      | 41 +++++++++++++++++++++++++
 2 files changed, 102 insertions(+)


base-commit: af6105afc67a15a491a0a4fd18a28c9f801a0b94

Comments

Ian Eure Nov. 30, 2023, 1:54 a.m. UTC | #1
Changes made:

 - Rebased and addressed conflicts.
 - Fixed a build failure.
 - Renamed from python-jellyfin-mpv-shim to jellyfin-mpv-shim.  I think the python- prefix is only needed for stuff like libraries, an end-uesr application like this shouldn't need the name of the programming language it's written in to be in the package name.

Ian Eure (4):
  gnu: Add python-mpv-jsonipc.
  gnu: Add python-jellyfin-apiclient.
  gnu: Add python-pystray.
  gnu: Add jellyfin-mpv-shim.

 gnu/packages/python-xyz.scm | 61 +++++++++++++++++++++++++++++++++++++
 gnu/packages/video.scm      | 41 +++++++++++++++++++++++++
 2 files changed, 102 insertions(+)


base-commit: bdbb9dc27a590b08651d058f06a42caa26e04abb
Sharlatan Hellseher Feb. 21, 2024, 8:42 p.m. UTC | #2
Hi Ian,

QA looks green ^.-

I've noticed some minor picks in v5 you sent.

--8<---------------cut here---------------start------------->8---
+(define-public jellyfin-mpv-shim
...
+    (license license:gpl2)))
--8<---------------cut here---------------end--------------->8---
Nix listes 5 licenses in the package
<https://github.com/NixOS/nixpkgs/blob/nixos-23.11/pkgs/applications/video/jellyfin-mpv-shim/default.nix#L109>
may you double check if it's still valid.

--8<---------------cut here---------------start------------->8---
+(define-public python-mpv-jsonipc
...
+    (synopsis "Python API to MPV using JSON IPC")
+    (description "Python API to MPV using JSON IPC")
--8<---------------cut here---------------end--------------->8---
The description of the package needs to be longer than synopsis and
needs to include more info. No full stop after end of the sentence.

--8<---------------cut here---------------start------------->8---
+(define-public python-jellyfin-apiclient
...
+    (synopsis "Python API client for Jellyfin")
+    (description "Python API client for Jellyfin")
--8<---------------cut here---------------end--------------->8---
Same here.

--8<---------------cut here---------------start------------->8---
+(define-public python-pystray
...
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'check)
+                   (delete 'sanity-check))))
--8<---------------cut here---------------end--------------->8---
Please use #:tests? flag and place some comments why it's disabled (no
tests, require network, all broken etc.). Does Sanity check fail due to
incompatible versions, if so consider add relax-requirement phase (see
code examples in python-xyz).

Thanks,
Oleg
Ian Eure Feb. 25, 2024, 10:03 p.m. UTC | #3
Hi Sharlatan,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> [[PGP Signed Part:Undecided]]
>
> Hi Ian,
>
> QA looks green ^.-
>
> I've noticed some minor picks in v5 you sent.
>

Thank you for the feedback, I sent an updated patch series.

I had to keep the sanity-check phase of jellyfin-mpv-shim removed, 
because the program is ill-behaved and tries to do stuff at module 
import time, which breaks the build.

Thanks,

  — Ian
Andreas Enge March 7, 2024, 7:32 p.m. UTC | #4
Hello,

during the online patch hacking session I just had time to apply the first
two patches. I have added a copyright line for you. And I changed the
license of the second one to gpl3+; unless specified otherwise, gpl always
carries forward.

Thanks!

Andreas
Andreas Enge March 8, 2024, 11:57 a.m. UTC | #5
3/5 pushed, after modifying the license to lgpl3+, see here:
   https://github.com/moses-palmer/pystray/blob/master/lib/pystray/__init__.py

Andreas
Andreas Enge March 8, 2024, 12:10 p.m. UTC | #6
Hello,

I also pushed 4/5, after removing a trailing #t in a phase and some
reformatting to make the lines shorter. Thanks for the detailed license
list!

I am not familiar enough with services to have a look at the last patch,
and will leave this to someone else. Since this issue has become quite
long with its 6 versions of patches, you may wish to close this bug and
then resubmit only the service part separately to make it look less
overwhelming for the service person.

Andreas
Ian Eure March 10, 2024, 5:15 a.m. UTC | #7
close 67120
thanks

Hi Andreas,

Thank you for the review and commits!  Looks like I missed your 
messages because I’m not subscribed to bug-guix and didn’t get 
cc’d.  I like your advice, I’ll get a new bug opened.

Ian Eure <ian@retrospec.tv> writes:

> Hi Sharlatan,
>
> Sharlatan Hellseher <sharlatanus@gmail.com> writes:
>
>> [[PGP Signed Part:Undecided]]
>>
>> Hi Ian,
>>
>> QA looks green ^.-
>>
>> I've noticed some minor picks in v5 you sent.
>>
>
> Thank you for the feedback, I sent an updated patch series.
>
> I had to keep the sanity-check phase of jellyfin-mpv-shim 
> removed,
> because the program is ill-behaved and tries to do stuff at 
> module
> import time, which breaks the build.
>
> Thanks,
>
>  — Ian
>