mbox series

[bug#67019,00/16] gnu: Add KaTeX, lessc, and flow-remove-types.

Message ID cover.1699540553.git.philip@philipmcgrath.com
Headers show
Series gnu: Add KaTeX, lessc, and flow-remove-types. | expand

Message

Philip McGrath Nov. 9, 2023, 4:06 p.m. UTC
Hi,

This patch series adds KaTeX, which renders TeX math notation to HTML and/or
MathML. (It's somewhat similar to MathJax, but with different emphases: in
particular, the rendered output from KaTeX doesn't require JavaScript.)

Along the way, this series adds two dependencies of KaTeX that are especially
notable in their own right:

 1. Patches 01/16 to 03/16 add lessc, the compiler for the Less CSS extension
    language (not to be confused with the pager less).

 2. Patches 04/16 to 11/16 add flow-remove-types, which erases Flow type
    annotations from JavaScript source code.  This enables Guix to build
    software written using Flow somewhat analagously to how esbuild does with
    TypeScript.

Philip

Philip McGrath (16):
  gnu: Add node-is-what.
  gnu: Add node-copy-anything.
  gnu: Add lessc.
  gnu: Add ocaml-wtf8.
  gnu: Add ocaml-visitors.
  gnu: Add ocaml-ppx-gen-rec.
  gnu: Add ocaml-dtoa.
  gnu: Add node-vlq.
  gnu: Add ocaml-flow-parser.
  gnu: Add node-flow-parser.
  gnu: Add flow-remove-types.
  gnu: js-commander: Update to 11.1.0.
  gnu: js-commander: Install as a node module.
  gnu: Add mftrace.
  gnu: Add font-katex.
  gnu: Add katex.

 gnu/packages/fontutils.scm  |  45 +++++
 gnu/packages/javascript.scm | 381 +++++++++++++++++++++++++++++++++--
 gnu/packages/node-xyz.scm   | 220 +++++++++++++++++++++
 gnu/packages/ocaml.scm      |  99 ++++++++++
 gnu/packages/web.scm        | 385 ++++++++++++++++++++++++++++++++++++
 5 files changed, 1113 insertions(+), 17 deletions(-)


base-commit: 19fe24c5b978a16cbca3cddbfa3ab9d1ee2c68f2