mbox series

[bug#66609,0/1] services: admin: Export rottlog-configuration accessors.

Message ID cover.1697641168.git.zimon.toutoune@gmail.com
Headers show
Series services: admin: Export rottlog-configuration accessors. | expand

Message

Simon Tournier Oct. 18, 2023, 3:08 p.m. UTC
Hi,

In some cases, people have a template configuration, and then another
configuration with some specific ’log-rotation’ files.  Then, they want to
custom-merge these configurations.  Therefore, they need to access field
values of <rottlog-configuration>.

For one trivial example: replace ’log-rotation’ of syslog defined with
%rotated-files by some others – do not ask why. :-)

--8<---------------cut here---------------start------------->8---
(use-modules (gnu services base)
             (gnu services admin)
             (srfi srfi-1))

(define config-template (rottlog-configuration))

(define some-logs
  (list (log-rotation
         (files '("/var/log/foo"
                  "/var/log/bar"
                  "/var/log/baz"))
         (frequency 'weekly)
         (options `("rotate 16"
                    "sharedscripts"
                    ,@%default-log-rotation-options)))
        (log-rotation
         (files '("/var/log/some-evil.log"))
         (options `("rotate 4"
                    ,@%default-log-rotation-options)))))

(define other-config (rottlog-configuration
                      (rotations some-logs)))

(define my-config
  (rottlog-configuration
   (inherit config-template)
   (rotations (filter
               (lambda (log)
                 (not (lset= eq? (log-rotation-files log) %rotated-files)))
               (append-map rottlog-configuration-rotations
                           (list other-config
                                 config-template))))))
--8<---------------cut here---------------end--------------->8---

Without this patch, it needs to rely on ’@@’ which is not nice.

--8<---------------cut here---------------start------------->8---
(define rottlog-configuration-rotations
  (@@ (gnu services admin) rottlog-rotations))
--8<---------------cut here---------------end--------------->8---

Therefore, let export them!  To stay consistent with the schema for naming,
the accessors are renamed rottlog-configuration-

Cheers,
simon



Simon Tournier (1):
  services: admin: Export rottlog-configuration accessors.

 gnu/services/admin.scm | 25 +++++++++++++++----------
 1 file changed, 15 insertions(+), 10 deletions(-)


base-commit: 202c97c4ce2e948266b8b6ee4d80631adbfba92b