mbox series

[bug#66030,0/2] Fix: Julia is very slow

Message ID cover.1694859477.git.zimon.toutoune@gmail.com
Headers show
Series Fix: Julia is very slow | expand

Message

Simon Tournier Sept. 16, 2023, 10:52 a.m. UTC
Hi,

This series is for triggering the rebuild of the Julia world.  Some Julia
packages are long to build so let minimize the annoyance and make some
substitutes available before pushing to master. :-)

        bug Julia is very slow
        Cayetano Santos via Bug reports for GNU Guix <bug-guix@gnu.org>
        Fri, 09 Jun 2023 23:42:00 +0200
        id:87legsl3cm.fsf@inventati.org
        https://yhetil.org/guix/87legsl3cm.fsf@inventati.org
        https://issues.guix.gnu.org/msgid/87legsl3cm.fsf@inventati.org


Cheers,
simon

Efraim Flashner (2):
  gnu: openblas-ilp64: Add symbol suffix.
  gnu: julia: Conditionally use openblas with ILP64 support.

 gnu/packages/julia.scm | 22 ++++++++++++++--------
 gnu/packages/maths.scm |  4 +++-
 2 files changed, 17 insertions(+), 9 deletions(-)


base-commit: eeec8371890fc95c60112da299dde78b21c948c2

Comments

Simon Tournier Sept. 17, 2023, 11:49 a.m. UTC | #1
Hi,

On Sat, 16 Sep 2023 at 12:52, Simon Tournier <zimon.toutoune@gmail.com> wrote:

> This series is for triggering the rebuild of the Julia world.  Some Julia
> packages are long to build so let minimize the annoyance and make some
> substitutes available before pushing to master. :-)

Now, QA is done.

     https://qa.guix.gnu.org/issue/66030

The change introduces a regression for the package julia-arraylayouts;
it is then fixed, see v2.

The regression about the package julia-genericlinearalgebra reads:

--8<---------------cut here---------------start------------->8---
Singular value decomposition |   57     57  1.7s
Hermitian: Error During Test at /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:12
  Got exception outside of a @test
  could not load symbol "dsfrk_64_":
  /gnu/store/h5mgc7ar7a05f9rwrd1makhzays5wd3s-julia-1.8.3/bin/../lib/julia/liblapack.so: undefined symbol: dsfrk_64_
  Stacktrace:
    [1] sfrk!(transr::Char, uplo::Char, trans::Char, alpha::Float64, A::Matrix{Float64}, beta::Float64, C::Vector{Float64})
      @ GenericLinearAlgebra.LAPACK2 /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/src/lapack.jl:523
    [2] Ac_mul_A_RFP(A::Matrix{Float64}, uplo::Symbol)
      @ GenericLinearAlgebra /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/src/rectfullpacked.jl:77
    [3] macro expansion
      @ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:13 [inlined]
    [4] macro expansion
      @ /gnu/store/h5mgc7ar7a05f9rwrd1makhzays5wd3s-julia-1.8.3/share/julia/stdlib/v1.8/Test/src/Test.jl:1360 [inlined]
    [5] macro expansion
      @ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:13 [inlined]
    [6] macro expansion
      @ /gnu/store/h5mgc7ar7a05f9rwrd1makhzays5wd3s-julia-1.8.3/share/julia/stdlib/v1.8/Test/src/Test.jl:1436 [inlined]
    [7] macro expansion
      @ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:7 [inlined]
    [8] macro expansion
      @ /gnu/store/h5mgc7ar7a05f9rwrd1makhzays5wd3s-julia-1.8.3/share/julia/stdlib/v1.8/Test/src/Test.jl:1360 [inlined]
    [9] top-level scope
      @ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/rectfullpacked.jl:7
   [10] include(fname::String)
      @ Base.MainInclude ./client.jl:476
   [11] top-level scope
      @ /gnu/store/zkx6p7kz3m5k5w5iy0l1d09b2n8b0ib3-julia-genericlinearalgebra-0.2.5/share/julia/loadpath/GenericLinearAlgebra/test/runtests.jl:10
   [12] include(mod::Module, _path::String)
      @ Base ./Base.jl:419
   [13] exec_options(opts::Base.JLOptions)
      @ Base ./client.jl:303
   [14] _start()
      @ Base ./client.jl:522
--8<---------------cut here---------------end--------------->8---

Any idea?

Cheers,
simon