mbox series

[bug#65280,00/26] Refresh Qt 6 packages

Message ID cover.1691986843.git.maxim.cournoyer@gmail.com
Headers show
Series Refresh Qt 6 packages | expand

Message

Maxim Cournoyer Aug. 14, 2023, 4:21 a.m. UTC
This series refreshes our modern Qt 6 packages to their latest release,
6.5.2.  It also adds some tooling for the Qt team in the form of two manifests
to select all the core Qt 5 packages or the other core packages.


Maxim Cournoyer (26):
  gnu: qt: Revert to use individual versions instead of %qt5-version.
  gnu: qtdeclarative: Disable QML cache to avoid stale cache issues.
  etc: Add Qt manifests for Qt maintenance.
  gnu: qtbase: Update to 6.5.2.
  gnu: qtbase: Enable zstd support.
  gnu: qt5compat: Update to 6.5.2.
  gnu: qtsvg: Update to 6.5.2.
  gnu: qtimageformats: Rename variable to qtimageformats-5.
  gnu: qtimageformats-5: Fix indentation.
  gnu: Add qtimageformats.
  gnu: Add qtlanguageserver.
  gnu: qtdeclarative: Update to 6.5.2.
  gnu: qtwebsockets: Update to 6.5.2.
  gnu: qtshadertools: Update to 6.5.2.
  gnu: qtmultimedia: Update to 6.5.2.
  gnu: qtwayland: Update to 6.5.2.
  gnu: qtwebchannel: Update to 6.5.2.
  gnu: qtlottie: Update to 6.5.2.
  gnu: qttools: Update to 6.5.2.
  gnu: qttranslations: Update to 6.5.2.
  gnu: qtpositioning: Update to 6.5.2.
  gnu: qtnetworkauth: Update to 6.5.2.
  gnu: qtremoteobjects: Update to 6.5.2.
  gnu: qtwebengine: Update to 6.5.2.
  gnu: Remove qtquickcontrols2.
  gnu: qt-creator: Update to 11.0.1.

 etc/teams/qt/common.scm                       |  50 +++
 etc/teams/qt/qt-manifest.scm                  |  34 ++
 etc/teams/qt/qt5-manifest.scm                 |  34 ++
 gnu/local.mk                                  |   2 +
 gnu/packages/geo.scm                          |   2 +-
 gnu/packages/image-viewers.scm                |   2 +-
 .../qtdeclarative-5-disable-qmlcache.patch    |  16 +
 .../qtdeclarative-disable-qmlcache.patch      |  16 +
 gnu/packages/qt.scm                           | 308 ++++++++++++------
 gnu/packages/telegram.scm                     |   2 +-
 10 files changed, 363 insertions(+), 103 deletions(-)
 create mode 100644 etc/teams/qt/common.scm
 create mode 100644 etc/teams/qt/qt-manifest.scm
 create mode 100644 etc/teams/qt/qt5-manifest.scm
 create mode 100644 gnu/packages/patches/qtdeclarative-5-disable-qmlcache.patch
 create mode 100644 gnu/packages/patches/qtdeclarative-disable-qmlcache.patch


base-commit: c5e2f55069658ea4e9febee1622f9e32dcbe2718
prerequisite-patch-id: 7498c01c0a80752067cc314a465373c7d8710657

Comments

宋文武 Aug. 16, 2023, 10:56 a.m. UTC | #1
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> This series refreshes our modern Qt 6 packages to their latest release,
> 6.5.2.  It also adds some tooling for the Qt team in the form of two manifests
> to select all the core Qt 5 packages or the other core packages.
>
>
> Maxim Cournoyer (26):
>   gnu: qt: Revert to use individual versions instead of %qt5-version.
>   gnu: qtdeclarative: Disable QML cache to avoid stale cache issues.
>   etc: Add Qt manifests for Qt maintenance.
>   gnu: qtbase: Update to 6.5.2.
>   gnu: qtbase: Enable zstd support.
>   gnu: qt5compat: Update to 6.5.2.
>   gnu: qtsvg: Update to 6.5.2.
>   gnu: qtimageformats: Rename variable to qtimageformats-5.
>   gnu: qtimageformats-5: Fix indentation.
>   gnu: Add qtimageformats.
>   gnu: Add qtlanguageserver.
>   gnu: qtdeclarative: Update to 6.5.2.
>   gnu: qtwebsockets: Update to 6.5.2.
>   gnu: qtshadertools: Update to 6.5.2.
>   gnu: qtmultimedia: Update to 6.5.2.
>   gnu: qtwayland: Update to 6.5.2.
>   gnu: qtwebchannel: Update to 6.5.2.
>   gnu: qtlottie: Update to 6.5.2.
>   gnu: qttools: Update to 6.5.2.
>   gnu: qttranslations: Update to 6.5.2.
>   gnu: qtpositioning: Update to 6.5.2.
>   gnu: qtnetworkauth: Update to 6.5.2.
>   gnu: qtremoteobjects: Update to 6.5.2.
>   gnu: qtwebengine: Update to 6.5.2.
>   gnu: Remove qtquickcontrols2.
>   gnu: qt-creator: Update to 11.0.1.
>

All look good to me, thanks!
Maxim Cournoyer Aug. 16, 2023, 12:19 p.m. UTC | #2
Hi 宋文武,

宋文武 <iyzsong@envs.net> writes:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> This series refreshes our modern Qt 6 packages to their latest release,
>> 6.5.2.  It also adds some tooling for the Qt team in the form of two manifests
>> to select all the core Qt 5 packages or the other core packages.
>>
>>
>> Maxim Cournoyer (26):
>>   gnu: qt: Revert to use individual versions instead of %qt5-version.
>>   gnu: qtdeclarative: Disable QML cache to avoid stale cache issues.
>>   etc: Add Qt manifests for Qt maintenance.
>>   gnu: qtbase: Update to 6.5.2.
>>   gnu: qtbase: Enable zstd support.
>>   gnu: qt5compat: Update to 6.5.2.
>>   gnu: qtsvg: Update to 6.5.2.
>>   gnu: qtimageformats: Rename variable to qtimageformats-5.
>>   gnu: qtimageformats-5: Fix indentation.
>>   gnu: Add qtimageformats.
>>   gnu: Add qtlanguageserver.
>>   gnu: qtdeclarative: Update to 6.5.2.
>>   gnu: qtwebsockets: Update to 6.5.2.
>>   gnu: qtshadertools: Update to 6.5.2.
>>   gnu: qtmultimedia: Update to 6.5.2.
>>   gnu: qtwayland: Update to 6.5.2.
>>   gnu: qtwebchannel: Update to 6.5.2.
>>   gnu: qtlottie: Update to 6.5.2.
>>   gnu: qttools: Update to 6.5.2.
>>   gnu: qttranslations: Update to 6.5.2.
>>   gnu: qtpositioning: Update to 6.5.2.
>>   gnu: qtnetworkauth: Update to 6.5.2.
>>   gnu: qtremoteobjects: Update to 6.5.2.
>>   gnu: qtwebengine: Update to 6.5.2.
>>   gnu: Remove qtquickcontrols2.
>>   gnu: qt-creator: Update to 11.0.1.
>>
>
> All look good to me, thanks!

Thanks!  I've decided to update our Qt 5 as well, included in a V2; I've
tested building all of these version 5.15.10 packages except qtwebengine
which is requires too much RAM to build on my desktop.  The new commits
are:

--8<---------------cut here---------------start------------->8---
0027-gnu-qtbase-5-Update-to-5.15.10.patch
0028-gnu-qt3d-5-Update-to-5.15.10.patch
0029-gnu-qtsvg-5-Update-to-5.15.10.patch
0030-gnu-qtimageformats-5-Update-to-5.15.10.patch
0031-gnu-qtx11extras-Update-to-5.15.10.patch
0032-gnu-qtxmlpatterns-Update-to-5.15.10.patch
0033-gnu-qtdeclarative-5-Update-to-5.15.10.patch
0034-gnu-qtconnectivity-Update-to-5.15.10.patch
0035-gnu-qtwebsockets-5-Update-to-5.15.10.patch
0036-gnu-qtsensors-Update-to-5.15.10.patch
0037-gnu-qtmultimedia-5-Update-to-5.15.10.patch
0038-gnu-qtsensors-Shorten-line-width.patch
0039-gnu-qtmultimedia-5-Shorten-maximum-line-width.patch
0040-gnu-qtwayland-5-Update-to-5.15.10.patch
0041-gnu-qtserialport-Update-to-5.15.10.patch
0042-gnu-qtserialbus-Update-to-5.15.10.patch
0043-gnu-qtwebchannel-5-Update-to-5.15.10.patch
0044-gnu-qtwebglplugin-Update-to-5.15.10.patch
0045-gnu-qtwebview-Update-to-5.15.10.patch
0046-gnu-qtlocation-Update-to-5.15.10.patch
0047-gnu-qttools-5-Update-to-5.15.10.patch
0048-gnu-qtscript-Update-to-5.15.10.patch
0049-gnu-qtquickcontrols-5-Update-to-5.15.10.patch
0050-gnu-qtquickcontrols2-5-Update-to-5.15.10.patch
0051-gnu-qtgraphicaleffects-Update-to-5.15.10.patch
0052-gnu-qtgamepad-Update-to-5.15.10.patch
0053-gnu-qtscxml-Update-to-5.15.10.patch
0054-gnu-qtpurchasing-Update-to-5.15.10.patch
0055-gnu-qtcharts-Update-to-5.15.10.patch
0056-gnu-qtdatavis3d-Update-to-5.15.10.patch
0057-gnu-qtnetworkauth-5-Update-to-5.15.10.patch
0058-gnu-qtspeech-Update-to-5.15.10.patch
0059-gnu-qtwebengine-5-Update-to-5.15.10.patch
--8<---------------cut here---------------end--------------->8---

Could you please take a look?  They are mostly bumps to the version and
hash of each package and fixes for 'guix lint'.
宋文武 Aug. 17, 2023, 11:56 a.m. UTC | #3
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> [...]
> Thanks!  I've decided to update our Qt 5 as well, included in a V2; I've
> tested building all of these version 5.15.10 packages except qtwebengine
> which is requires too much RAM to build on my desktop.  The new commits
> are:
>
> 0027-gnu-qtbase-5-Update-to-5.15.10.patch
> 0028-gnu-qt3d-5-Update-to-5.15.10.patch
> 0029-gnu-qtsvg-5-Update-to-5.15.10.patch
> 0030-gnu-qtimageformats-5-Update-to-5.15.10.patch
> 0031-gnu-qtx11extras-Update-to-5.15.10.patch
> 0032-gnu-qtxmlpatterns-Update-to-5.15.10.patch
> 0033-gnu-qtdeclarative-5-Update-to-5.15.10.patch
> 0034-gnu-qtconnectivity-Update-to-5.15.10.patch
> 0035-gnu-qtwebsockets-5-Update-to-5.15.10.patch
> 0036-gnu-qtsensors-Update-to-5.15.10.patch
> 0037-gnu-qtmultimedia-5-Update-to-5.15.10.patch
> 0038-gnu-qtsensors-Shorten-line-width.patch
> 0039-gnu-qtmultimedia-5-Shorten-maximum-line-width.patch
> 0040-gnu-qtwayland-5-Update-to-5.15.10.patch
> 0041-gnu-qtserialport-Update-to-5.15.10.patch
> 0042-gnu-qtserialbus-Update-to-5.15.10.patch
> 0043-gnu-qtwebchannel-5-Update-to-5.15.10.patch
> 0044-gnu-qtwebglplugin-Update-to-5.15.10.patch
> 0045-gnu-qtwebview-Update-to-5.15.10.patch
> 0046-gnu-qtlocation-Update-to-5.15.10.patch
> 0047-gnu-qttools-5-Update-to-5.15.10.patch
> 0048-gnu-qtscript-Update-to-5.15.10.patch
> 0049-gnu-qtquickcontrols-5-Update-to-5.15.10.patch
> 0050-gnu-qtquickcontrols2-5-Update-to-5.15.10.patch
> 0051-gnu-qtgraphicaleffects-Update-to-5.15.10.patch
> 0052-gnu-qtgamepad-Update-to-5.15.10.patch
> 0053-gnu-qtscxml-Update-to-5.15.10.patch
> 0054-gnu-qtpurchasing-Update-to-5.15.10.patch
> 0055-gnu-qtcharts-Update-to-5.15.10.patch
> 0056-gnu-qtdatavis3d-Update-to-5.15.10.patch
> 0057-gnu-qtnetworkauth-5-Update-to-5.15.10.patch
> 0058-gnu-qtspeech-Update-to-5.15.10.patch
> 0059-gnu-qtwebengine-5-Update-to-5.15.10.patch
>
> Could you please take a look?  They are mostly bumps to the version and
> hash of each package and fixes for 'guix lint'.

Yes, those look great to me too!  Thanks.
Maxim Cournoyer Aug. 17, 2023, 1:47 p.m. UTC | #4
Hello 宋文武,

宋文武 <iyzsong@envs.net> writes:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> [...]
>> Thanks!  I've decided to update our Qt 5 as well, included in a V2; I've
>> tested building all of these version 5.15.10 packages except qtwebengine
>> which is requires too much RAM to build on my desktop.  The new commits
>> are:
>>
>> 0027-gnu-qtbase-5-Update-to-5.15.10.patch
>> 0028-gnu-qt3d-5-Update-to-5.15.10.patch
>> 0029-gnu-qtsvg-5-Update-to-5.15.10.patch
>> 0030-gnu-qtimageformats-5-Update-to-5.15.10.patch
>> 0031-gnu-qtx11extras-Update-to-5.15.10.patch
>> 0032-gnu-qtxmlpatterns-Update-to-5.15.10.patch
>> 0033-gnu-qtdeclarative-5-Update-to-5.15.10.patch
>> 0034-gnu-qtconnectivity-Update-to-5.15.10.patch
>> 0035-gnu-qtwebsockets-5-Update-to-5.15.10.patch
>> 0036-gnu-qtsensors-Update-to-5.15.10.patch
>> 0037-gnu-qtmultimedia-5-Update-to-5.15.10.patch
>> 0038-gnu-qtsensors-Shorten-line-width.patch
>> 0039-gnu-qtmultimedia-5-Shorten-maximum-line-width.patch
>> 0040-gnu-qtwayland-5-Update-to-5.15.10.patch
>> 0041-gnu-qtserialport-Update-to-5.15.10.patch
>> 0042-gnu-qtserialbus-Update-to-5.15.10.patch
>> 0043-gnu-qtwebchannel-5-Update-to-5.15.10.patch
>> 0044-gnu-qtwebglplugin-Update-to-5.15.10.patch
>> 0045-gnu-qtwebview-Update-to-5.15.10.patch
>> 0046-gnu-qtlocation-Update-to-5.15.10.patch
>> 0047-gnu-qttools-5-Update-to-5.15.10.patch
>> 0048-gnu-qtscript-Update-to-5.15.10.patch
>> 0049-gnu-qtquickcontrols-5-Update-to-5.15.10.patch
>> 0050-gnu-qtquickcontrols2-5-Update-to-5.15.10.patch
>> 0051-gnu-qtgraphicaleffects-Update-to-5.15.10.patch
>> 0052-gnu-qtgamepad-Update-to-5.15.10.patch
>> 0053-gnu-qtscxml-Update-to-5.15.10.patch
>> 0054-gnu-qtpurchasing-Update-to-5.15.10.patch
>> 0055-gnu-qtcharts-Update-to-5.15.10.patch
>> 0056-gnu-qtdatavis3d-Update-to-5.15.10.patch
>> 0057-gnu-qtnetworkauth-5-Update-to-5.15.10.patch
>> 0058-gnu-qtspeech-Update-to-5.15.10.patch
>> 0059-gnu-qtwebengine-5-Update-to-5.15.10.patch
>>
>> Could you please take a look?  They are mostly bumps to the version and
>> hash of each package and fixes for 'guix lint'.
>
> Yes, those look great to me too!  Thanks.

Thank you!

I'll open the merge request already, although it seems QA is a bit
behind and hasn't provided any insights into the branch yet -- I had
manually built all but one package and don't expect Qt applications to
break on a patch level update.
Maxim Cournoyer Aug. 22, 2023, 4:36 p.m. UTC | #5
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> This series refreshes our modern Qt 6 packages to their latest release,
> 6.5.2.  It also adds some tooling for the Qt team in the form of two manifests
> to select all the core Qt 5 packages or the other core packages.

The qt-updates branch has now been merged.  Thanks for your attention!