mbox series

[bug#65230,00/13] Fix 'guix refresh' for Qt and other packages

Message ID cover.1691779207.git.maxim.cournoyer@gmail.com
Headers show
Series Fix 'guix refresh' for Qt and other packages | expand

Message

Maxim Cournoyer Aug. 11, 2023, 6:42 p.m. UTC
Hi,

This series improves our generic HTML updater, so that it knows to update
packages using a mirror:// URL, or which URL contains versioned items in its
path.  With a trivial change to the release-file? procedure, this enables the
automatic updates of our many Qt packages.

Thanks,

Maxim Cournoyer (13):
  gnu-maintenance: Make base-url argument of import-html-release
    required.
  download: Add mirrors for Qt.
  gnu: qt: Streamline qt-urls.
  gnu: qt-creator: Use mirror://qt for source URI.
  gnu-maintenance: Fix docstring.
  gnu-maintenance: Extract url->links procedure.
  gnu-maintenance: Fix indentation.
  gnu-maintenance: Accept package object in 'import-html-release'
    procedure.
  gnu-maintenance: Document nested procedures in 'import-html-release'.
  gnu-maintenance: Extract 'canonicalize-url' from
    'import-html-release'.
  gnu-maintenance: Add support to rewrite version in URL path.
  gnu-maintenance: Allow mirror URLs to fallback to the generic HTML
    updater.
  gnu-maintenance: Consider Qt source tarballs as "release files".

 gnu/packages/qt.scm       | 126 +++++++--------
 guix/download.scm         |  14 +-
 guix/gnu-maintenance.scm  | 325 ++++++++++++++++++++++++++------------
 tests/gnu-maintenance.scm |  47 +++++-
 4 files changed, 338 insertions(+), 174 deletions(-)


base-commit: 77251c5f5af193dcd031dffef744001cfc48f7e5