mbox series

[bug#65229,0/2] Add '-q' for 'pull' and 'time-machine'; support loading from pipes

Message ID cover.1691767568.git.ludo@gnu.org
Headers show
Series Add '-q' for 'pull' and 'time-machine'; support loading from pipes | expand

Message

Ludovic Courtès Aug. 11, 2023, 3:31 p.m. UTC
Hello!

These patches address two related issues:

  • The first one adds ‘-q’ to ‘pull’ and ‘time-machine’ to
    instruct them to ignore the user/system ‘channels.scm’ file.
    That way, a command like the following is guaranteed to have
    the same semantics regardless of available config files:

      guix time-machine -q --commit=v1.2.0 -- build hello

    This issue had been raised in
    <https://issues.guix.gnu.org/63726>.

  • The second one lets users do things (in Bash) like:

      guix time-machine -C <(echo %default-channels) -- …

Feedback welcome!

Ludo’.

Ludovic Courtès (2):
  pull, time-machine: Add '-q' to ignore channel files.
  ui: 'load*' accepts /dev/fd/N files pointing to a pipe.

 doc/guix.texi                 | 30 ++++++++++++++++++++++--------
 guix/scripts/pull.scm         | 14 ++++++++++++--
 guix/scripts/time-machine.scm |  7 ++++++-
 guix/ui.scm                   | 16 +++++++++++++++-
 tests/guix-build.sh           |  9 ++++++++-
 5 files changed, 63 insertions(+), 13 deletions(-)


base-commit: 56fddefc6de3b0c1f2ccb9559d86ba08d2e429b9