mbox series

[bug#64356,0/4] Fix GDM and VNC tests

Message ID cover.1688070852.git.mirai@makinata.eu
Headers show
Series Fix GDM and VNC tests | expand

Message

Bruno Victal June 29, 2023, 8:39 p.m. UTC
It turns out that the issue with the xvnc test was due to using invoke
instead of system*.
Along the way, the GDM test was refactored to replace the ugly sleep
delay with a more adequate awaiting method.

Bruno Victal (4):
  tests: xvnc: Fix test.
  marionette: Allow passing custom OCR arguments.
  tests: gdm: Prefer OCR to delay.
  tests: xvnc: Group up GDM test.

 gnu/build/marionette.scm | 34 +++++++++++++++++-------
 gnu/tests/gdm.scm        | 19 ++++++++++----
 gnu/tests/vnc.scm        | 56 ++++++++++++++++++++--------------------
 3 files changed, 67 insertions(+), 42 deletions(-)


base-commit: 94ac93042f09b4ba68b7b64ed1feeebd3dab1ea4

Comments

Maxim Cournoyer July 1, 2023, 3:23 a.m. UTC | #1
Hi Bruno!

Bruno Victal <mirai@makinata.eu> writes:

> It turns out that the issue with the xvnc test was due to using invoke
> instead of system*.
> Along the way, the GDM test was refactored to replace the ugly sleep
> delay with a more adequate awaiting method.
>
> Bruno Victal (4):
>   tests: xvnc: Fix test.
>   marionette: Allow passing custom OCR arguments.
>   tests: gdm: Prefer OCR to delay.
>   tests: xvnc: Group up GDM test.
>
>  gnu/build/marionette.scm | 34 +++++++++++++++++-------
>  gnu/tests/gdm.scm        | 19 ++++++++++----
>  gnu/tests/vnc.scm        | 56 ++++++++++++++++++++--------------------
>  3 files changed, 67 insertions(+), 42 deletions(-)

So the xvnc service is not broken per se?  I thought I had a black
screen on GDM, when using the (xdmcp? #t) to login via the GDM screen.
Maybe just a fluke in the midst of upgrades?  I'll double check, and if
there's indeed no issue, look deeper into this promising series!
Maxim Cournoyer July 19, 2023, 2:50 p.m. UTC | #2
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hi Bruno!
>
> Bruno Victal <mirai@makinata.eu> writes:
>
>> It turns out that the issue with the xvnc test was due to using invoke
>> instead of system*.
>> Along the way, the GDM test was refactored to replace the ugly sleep
>> delay with a more adequate awaiting method.
>>
>> Bruno Victal (4):
>>   tests: xvnc: Fix test.
>>   marionette: Allow passing custom OCR arguments.
>>   tests: gdm: Prefer OCR to delay.
>>   tests: xvnc: Group up GDM test.

Applied, with some modifications mentioned in the thread.

Thanks a lot!