mbox series

[bug#64188,v2,0/7] More package tuning

Message ID cover.1687781377.git.efraim@flashner.co.il
Headers show
Series More package tuning | expand

Message

Efraim Flashner June 26, 2023, 12:38 p.m. UTC
I hope I've addressed the comments with this patch series. I've changed
the language to use psabi or to refer to 'generalized optimizations'.
The go adaptations for tuning are now part of
build-system-with-tuning-compiler, with an adjustment made to (also)
check the psabi listing when it comes to the go compiler.


Efraim Flashner (7):
  gnu: %gcc-11-x86_64-micro-architectures: Add psabi entries.
  guix: cpu: Add generalized CPU matching.
  guix: cpu: Rewrite fallback for x86_64 cpu->gcc-architecture.
  guix: cpu: Refactor cpu->gcc-architecture.
  guix: cpu: Add gcc-architecture->micro-architecture-level mapping.
  gnu: go: Add CPU tuning targets.
  transformations: Allow tuning go packages.

 gnu/packages/gcc.scm     |   5 +-
 gnu/packages/golang.scm  |  23 ++++++-
 guix/cpu.scm             | 130 ++++++++++++++++++++++-----------------
 guix/transformations.scm |  37 +++++++++--
 4 files changed, 133 insertions(+), 62 deletions(-)


base-commit: e85593b36b3874227ba812f47113441928c0f0c1