mbox series

[bug#63985,RFC,0/5] Generic INI serializer & SRFI-171 for define-configuration

Message ID cover.1686343642.git.mirai@makinata.eu
Headers show
Series Generic INI serializer & SRFI-171 for define-configuration | expand

Message

Bruno Victal June 9, 2023, 9:18 p.m. UTC
This RFC patch series (more like 3 patch series for the price of 1)
implements the following:

* Serializer Keyword arguments parameter in define-configuration.
  Allows for serializing procedures to be specified as:
    (define* (serialize-string field-name value #:key …)
      …)
  Examples in the unit tests.

* Express serialize-configuration with SRFI-171 transducers.
  The ‘base-transducer’ can be used to craft more specialized
  configuration record serializers.

* Generic INI serializer.
  This procedure can be used for crafting INI files from a
  record-type defined with define-configuration.
  Example for generic-ini in action can be found in the unit test.


These changes are motivated in part by a (in progress) refactoring of
the NetworkManager service-type.

Notes:
* I've left Generic-INI and serializer-kwargs undocumented since this
  is at its RFC stage.
* The (gnu services configuration generic-ini) module contains some trailing
  notes that should be removed before merging in.
* jami-account->alist explicitly checks for the empty-string.
  (which I consider to be a serialization “artifact” arising from define-maybe)
  This is the only (relevant) test that failed and will need to be investigated.

Bruno Victal (5):
  services: configuration: Simplify normalize-extra-args.
  services: configuration: Use transducers within
    serialize-configuration.
  services: fstrim-service-type: Serialize with SRFI-171 transducers.
  services: configuration: Add serializer-kwargs field.
  services: configuration: New generic-ini module.

 Makefile.am                                  |   1 +
 gnu/local.mk                                 |   1 +
 gnu/services/configuration.scm               |  86 +++++++++----
 gnu/services/configuration/generic-ini.scm   | 129 +++++++++++++++++++
 gnu/services/linux.scm                       |  11 +-
 tests/services/configuration.scm             |  38 +++++-
 tests/services/configuration/generic-ini.scm | 106 +++++++++++++++
 7 files changed, 333 insertions(+), 39 deletions(-)
 create mode 100644 gnu/services/configuration/generic-ini.scm
 create mode 100644 tests/services/configuration/generic-ini.scm


base-commit: c348b1be3891e6eb47bbdd9fc1587aba2b6ab0b7

Comments

Bruno Victal Oct. 7, 2023, 3:57 p.m. UTC | #1
Notable changes since v3:
* Reduced series scope for SRFI-171 related changes and documentation
improvements.
* Added docstrings.
  Note: docstring for `serialize-configuration' lifted from guix.texi.
* Addressed feedback from v3.

Bruno Victal (5):
  services: configuration: Simplify normalize-extra-args.
  services: configuration: Use transducers within
    serialize-configuration.
  services: fstrim-service-type: Serialize with SRFI-171 transducers.
  doc: Rewrite define-configuration.
  services: configuration: Add some commonly used predicates.

 doc/guix.texi                    | 108 +++++++++++++------------------
 gnu/services/audio.scm           |   7 +-
 gnu/services/configuration.scm   |  81 +++++++++++++++++------
 gnu/services/linux.scm           |  11 ++--
 gnu/services/telephony.scm       |  49 ++++++--------
 tests/services/configuration.scm |   6 +-
 6 files changed, 136 insertions(+), 126 deletions(-)


base-commit: b566e1a98a74d84d3978cffefd05295602c9445d