mbox series

[bug#63402,v4,0/4] Implement a dynamic IP monitoring feature.

Message ID cover.1684431342.git.maxim.cournoyer@gmail.com
Headers show
Series Implement a dynamic IP monitoring feature. | expand

Message

Maxim Cournoyer May 18, 2023, 5:48 p.m. UTC
Hello,

This fourth revision reworks the monitoring script to use 'wg set' to
reset the affected endpoint instead of restarting the whole service.

It also applies an upstream patch to the kernel that resolves the bug
where keep-alive would not work to (re)establish a session after it
was lost (e.g. when the listener's dynamic IP changed with an
interruption to its Internet service), instead of applying a
workaround to our PostUp command.

Thanks,

Maxim Cournoyer (4):
  services: wireguard: Implement a dynamic IP monitoring feature.
  services: wireguard: Clean-up configuration file serializer.
  services: wireguard: Add a 'configuration' action.
  gnu: linux-libre: Apply wireguard patch fixing keep-alive bug.

 Makefile.am                                   |   1 +
 doc/guix.texi                                 |  19 +-
 gnu/local.mk                                  |   1 +
 gnu/packages/linux.scm                        |  27 +-
 ...linux-libre-wireguard-postup-privkey.patch | 119 ++++++++
 gnu/services/vpn.scm                          | 265 +++++++++++++-----
 tests/services/vpn.scm                        |  83 ++++++
 7 files changed, 427 insertions(+), 88 deletions(-)
 create mode 100644 gnu/packages/patches/linux-libre-wireguard-postup-privkey.patch
 create mode 100644 tests/services/vpn.scm


base-commit: 5b700945fb0b33eec410de8979cae2fbf0d4f118