mbox series

[bug#63522,0/2] Fix return code of "guix import elpa"

Message ID cover.1684171669.git.zimon.toutoune@gmail.com
Headers show
Series Fix return code of "guix import elpa" | expand

Message

Simon Tournier May 15, 2023, 5:44 p.m. UTC
Hi,

This fixes issue #58308 [1]:

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix import elpa syslog
guix import: error: failed to download meta-data for package 'syslog'
$ echo $?
1

$ ./pre-inst-env guix import elpa syslog -r
guix import: error: failed to download meta-data for package 'syslog'
$ echo $?
1
--8<---------------cut here---------------end--------------->8---

In addition, since Elpa importer does not support the specification of the
version, the first patch warns about that:

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix import elpa -a melpa magit@12
guix import: warning: this importer does not consider the version
(package
  ((name "emacs-magit")
   (version "20230510.2139")
[...]
--8<---------------cut here---------------end--------------->8---

1: https://issues.guix.gnu.org/issue/58308


Cheers,
simon


Simon Tournier (2):
  scripts: import: elpa: Warn when version is specified.
  scripts: import: elpa: Return consistent error code.

 guix/scripts/import/elpa.scm | 34 ++++++++++++++++++++--------------
 1 file changed, 20 insertions(+), 14 deletions(-)


base-commit: 6e38ec447f98383e0722ac300734f8d7c8c5c7b0

Comments

Josselin Poiret May 17, 2023, 9:27 p.m. UTC | #1
Hi Simon,

Simon Tournier <zimon.toutoune@gmail.com> writes:

> Simon Tournier (2):
>   scripts: import: elpa: Warn when version is specified.
>   scripts: import: elpa: Return consistent error code.
>
>  guix/scripts/import/elpa.scm | 34 ++++++++++++++++++++--------------
>  1 file changed, 20 insertions(+), 14 deletions(-)

LGTM, applied as d81701a85aa8aa96f4a853f06fe28693fa8bee12.

Thanks!

Best,