mbox series

[bug#63330,0/4] Functional programming? In my C++?! It's more likely than you think!

Message ID cover.1683389080.git.liliana.prikler@gmail.com
Headers show
Series Functional programming? In my C++?! It's more likely than you think! | expand

Message

Liliana Marie Prikler May 6, 2023, 4:04 p.m. UTC
Hi Guix,

the following series adds a couple of packages that implement immutable
data structures, functional composition and all that good stuff.

Cheers

Liliana Marie Prikler (4):
  gnu: Add c-rrb.
  gnu: Add immer.
  gnu: Add zug.
  gnu: Add lager.

 gnu/packages/c.scm   | 25 ++++++++++++
 gnu/packages/cpp.scm | 90 ++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 115 insertions(+)


base-commit: 7368020bef3bf5a44100c59a973412f9e254e7c6

Comments

Liliana Marie Prikler May 6, 2023, 4:04 p.m. UTC | #1
Hi Guix,

the following series adds a couple of packages that implement immutable
data structures, functional composition and all that good stuff.

Cheers

Liliana Marie Prikler (4):
  gnu: Add c-rrb.
  gnu: Add immer.
  gnu: Add zug.
  gnu: Add lager.

 gnu/packages/c.scm   | 25 ++++++++++++
 gnu/packages/cpp.scm | 90 ++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 115 insertions(+)


base-commit: 7368020bef3bf5a44100c59a973412f9e254e7c6