mbox series

[bug#58261,00/11] Add rdkit.

Message ID cover.1664725832.git.david.elsing@posteo.net
Headers show
Series Add rdkit. | expand

Message

David Elsing Oct. 2, 2022, 10:55 p.m. UTC
Hello!

This patch series adds rdkit and its new dependencies.

Most optional components are enabled, except for the additional wrappers,
the "StructChecker" and the "compressed MolSuppliers".
All bundled software in External/ is unbundled and the included pickled data
(only used for a few tests) is removed.

freesasa is built as a shared library and the flex and bison files are generated.

For yaehmop-tightbind, I removed the transpiled Fortran->C files and built the
Fortran parts with GFortran instead.

gemmi included a patched version of sajson where numbers are kept as the
original strings, so I made a package variant and added a check for
sajson::TYPE_INTEGER in gemmi.
sajson also requires another small patch
(gnu/packages/patches/sajson-parse_flags-linking.patch) which I took from the
unmerged upstream pull request
https://github.com/chadaustin/sajson/pull/54/files, is that ok?

The packages were reproducible after two rounds (when setting the environment
variables as in python-build-system for rdkit), but I only built them on
x86_64 as emulation would take quite long.

David Elsing (11):
  gnu: Add fast-float.
  gnu: Add pocketfft.
  gnu: Add sajson.
  gnu: Add tinydir.
  gnu: Add optionparser.
  gnu: Add gemmi.
  gnu: Add freesasa.
  gnu: Add maeparser.
  gnu: Add coordgenlibs.
  gnu: Add yaehmop-tightbind.
  gnu: Add rdkit.

 gnu/packages/chemistry.scm                    | 531 ++++++++++++++++++
 gnu/packages/cpp.scm                          | 201 +++++++
 .../patches/gemmi-fix-sajson-types.patch      |  11 +
 .../rdkit-cmake-external-dependencies.patch   | 102 ++++
 .../sajson-for-gemmi-numbers-as-strings.patch | 195 +++++++
 .../patches/sajson-parse_flags-linking.patch  |  45 ++
 6 files changed, 1085 insertions(+)
 create mode 100644 gnu/packages/patches/gemmi-fix-sajson-types.patch
 create mode 100644 gnu/packages/patches/rdkit-cmake-external-dependencies.patch
 create mode 100644 gnu/packages/patches/sajson-for-gemmi-numbers-as-strings.patch
 create mode 100644 gnu/packages/patches/sajson-parse_flags-linking.patch