mbox series

[bug#57515,0/8] Stop unmirroring during updates.

Message ID cover.1662022775.git.maximedevos@telenet.be
Headers show
Series Stop unmirroring during updates. | expand

Message

M Sept. 1, 2022, 9 a.m. UTC
This patch series fixes #57477
(‘"guix refresh -u" sometimes 'unmirrors' source URLs’)
(at least, for the cases that I tested).  The individual commits
have proposals for what packages to test things on.

Due to the new behaviour of 'latest-html-release', a few
simplifications were possible in other updaters.  However,
to keep 57477 fixed, some URLs in (guix download) had to be
switched from http to https.

I'm currently running "make check", not yet completed.

Maxime Devos (8):
  guix: Extract logic of the check-mirror-url.
  gnu-maintenance: Produce mirror:// URIs in latest-ftp-release.
  gnu-maintenance: Produce mirror:// URIs in latest-html-release.
  download: Switch savannah mirrors to HTTPS URLs.
  gnu-maintenance: Simplify latest-savannah-release.
  download: Add a kernel.org mirror.
  gnu-maintenance: Simplify latest-kernel.org-release.
  gnu-maintenance: Remove unused procedures.

 guix/download.scm        | 17 ++++-----
 guix/gnu-maintenance.scm | 74 ++++++++++++++++++++++------------------
 guix/lint.scm            | 23 ++++---------
 3 files changed, 56 insertions(+), 58 deletions(-)


base-commit: 57f8f69562e942557e3331bb81c7e4acd973d189

Comments

M Sept. 1, 2022, 9:05 a.m. UTC | #1
> TODO: test case, it's http!
Oops I forgot this TODO, I'll try writing one.
M Sept. 1, 2022, 9:27 a.m. UTC | #2
On 01-09-2022 11:00, Maxime Devos wrote:
> This patch series fixes #57477
> (‘"guix refresh -u" sometimes 'unmirrors' source URLs’)
> (at least, for the cases that I tested).  The individual commits
> have proposals for what packages to test things on.
>
> Due to the new behaviour of 'latest-html-release', a few
> simplifications were possible in other updaters.  However,
> to keep 57477 fixed, some URLs in (guix download) had to be
> switched from http to https.
>
> I'm currently running "make check", not yet completed.

A guix-system test fails:

Authenticating channel 'guix', commits 9edb3f6 to a6a1b17 (40.004 new 
commits)...
  [ ]guix system: error: could not authenticate commit 
a6a1b17f29411c44cdda8d0cdf24acd472645140: key C1F3 3EE2 0C52 8FDB 7DD7  
011F 49E3 EE22 1917 25

but this appears unrelated (though TBI I suppose).

Greetings,
Maxime.
M Sept. 1, 2022, 10:13 a.m. UTC | #3
On 01-09-2022 11:05, Maxime Devos wrote:
>
>> TODO: test case, it's http!
> Oops I forgot this TODO, I'll try writing one.
Done in the 9th patch
Ludovic Courtès Sept. 26, 2022, 8:35 p.m. UTC | #4
Hi,

Maxime Devos <maximedevos@telenet.be> skribis:

>   guix: Extract logic of the check-mirror-url.
>   gnu-maintenance: Produce mirror:// URIs in latest-ftp-release.
>   gnu-maintenance: Produce mirror:// URIs in latest-html-release.
>   download: Switch savannah mirrors to HTTPS URLs.
>   gnu-maintenance: Simplify latest-savannah-release.
>   download: Add a kernel.org mirror.
>   gnu-maintenance: Simplify latest-kernel.org-release.
>   gnu-maintenance: Remove unused procedures.

I applied the whole series, with cosmetic changes on the first patch
and minor tweaks to the commit logs.

Thanks!

Ludo’.