mbox series

[bug#56759,00/20] gnu: Add AnyStyle.

Message ID cover.1658750358.git.philip@philipmcgrath.com
Headers show
Series gnu: Add AnyStyle. | expand

Message

Philip McGrath July 25, 2022, 12:13 p.m. UTC
Hi,

This patch series adds AnyStyle, a Ruby library and command-line tool
for parsing academic reference lists and bibliographies. (There as also
an AGPL web application that runs at <https://anystyle.io>, but I
haven't packaged that in this series.)

 -Philip

Philip McGrath (20):
  gnu: Add ruby-wapiti.
  gnu: Add ruby-namae.
  gnu: Add itex2mml.
  gnu: Add ruby-ritex.
  gnu: Add ruby-latex-decode.
  gnu: Add ruby-link-header.
  gnu: Add ruby-rdf.
  gnu: Add ruby-rdf-vocab.
  gnu: Add ruby-bibtex-ruby.
  gnu: Add ruby-unicode-scripts.
  gnu: Add ruby-citeproc.
  gnu: Add ruby-edtf.
  gnu: Add ruby-gli.
  gnu: Add ruby-anystyle-data.
  gnu: Add ruby-anystyle.
  gnu: Add anystyle.
  gnu: ruby-anystyle-data: Don't write to installed gem.
  gnu: ruby-anystyle: Initialize dictionary files.
  gnu: anystyle: Add tests for dictionary adapters.
  gnu: anystyle: Use GDBM by default.

 gnu/local.mk                                  |   3 +
 gnu/packages/maths.scm                        |  53 ++
 ...ruby-anystyle-data-immutable-install.patch |  40 +
 ...uby-anystyle-fix-dictionary-populate.patch |  94 +++
 .../patches/ruby-latex-decode-fix-test.patch  |  66 ++
 gnu/packages/ruby.scm                         | 751 ++++++++++++++++++
 6 files changed, 1007 insertions(+)
 create mode 100644 gnu/packages/patches/ruby-anystyle-data-immutable-install.patch
 create mode 100644 gnu/packages/patches/ruby-anystyle-fix-dictionary-populate.patch
 create mode 100644 gnu/packages/patches/ruby-latex-decode-fix-test.patch


base-commit: 212ca81895b2baa819ea11a308ad21880b84a546

Comments

Ludovic Courtès Aug. 4, 2022, 9:57 a.m. UTC | #1
Hi,

Philip McGrath <philip@philipmcgrath.com> skribis:

> This patch series adds AnyStyle, a Ruby library and command-line tool
> for parsing academic reference lists and bibliographies. (There as also
> an AGPL web application that runs at <https://anystyle.io>, but I
> haven't packaged that in this series.)

The tool looks quite impressive.

>   gnu: Add ruby-wapiti.
>   gnu: Add ruby-namae.
>   gnu: Add itex2mml.
>   gnu: Add ruby-ritex.
>   gnu: Add ruby-latex-decode.
>   gnu: Add ruby-link-header.
>   gnu: Add ruby-rdf.
>   gnu: Add ruby-rdf-vocab.
>   gnu: Add ruby-bibtex-ruby.
>   gnu: Add ruby-unicode-scripts.
>   gnu: Add ruby-citeproc.
>   gnu: Add ruby-edtf.
>   gnu: Add ruby-gli.
>   gnu: Add ruby-anystyle-data.
>   gnu: Add ruby-anystyle.
>   gnu: Add anystyle.
>   gnu: ruby-anystyle-data: Don't write to installed gem.
>   gnu: ruby-anystyle: Initialize dictionary files.
>   gnu: anystyle: Add tests for dictionary adapters.
>   gnu: anystyle: Use GDBM by default.

Applied, thanks!

Ludo’.