mbox series

[bug#56139,0/4] Make window managers use libinput-minimal instead of libinput

Message ID cover.1655899834.git.dev@jpoiret.xyz
Headers show
Series Make window managers use libinput-minimal instead of libinput | expand

Message

Josselin Poiret June 22, 2022, 12:14 p.m. UTC
This reduces their total closure, since libinput pulls in gtk+ which
adds roughly 400MiB.

Josselin Poiret (4):
  gnu: wlroots: Replace input libinput by libinput-minimal.
  gnu: sway: Replace input libinput by libinput-minimal.
  gnu: waybar: Replace input libinput by libinput-minimal.
  gnu: hikari: Replace input libinput by libinput-minimal.

 gnu/packages/wm.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: e74fa406e1043547242a8b67ab9907fea7aae6b9

Comments

Ludovic Courtès June 23, 2022, 8:20 p.m. UTC | #1
Hi,

Josselin Poiret <dev@jpoiret.xyz> skribis:

> This reduces their total closure, since libinput pulls in gtk+ which
> adds roughly 400MiB.

Good catch; applied, thanks!

It never occurred to me that it could depend on GTK+; apparently that’s
for some debugging GUI, but it’s not clear how it’s supposed to get
invoked:

--8<---------------cut here---------------start------------->8---
$ grep -r 2i4ykhraljp7jhhs76v44c51kkz31f01 $(guix build libinput)
grep: /gnu/store/brbdvjj4k9g80c2vdv8cfkckwd1q9dsk-libinput-1.19.2/libexec/libinput/libinput-debug-gui: binary file matches
grep: /gnu/store/brbdvjj4k9g80c2vdv8cfkckwd1q9dsk-libinput-1.19.2/etc/ld.so.cache: binary file matches
$ grep -r libinput-debug-gui $(guix build libinput)
$ echo $?
1
--8<---------------cut here---------------end--------------->8---

What’s is it used for?

Ludo’.
M June 23, 2022, 8:34 p.m. UTC | #2
Ludovic Courtès schreef op do 23-06-2022 om 22:20 [+0200]:
> Hi,
> 
> Josselin Poiret <dev@jpoiret.xyz> skribis:
> 
> > This reduces their total closure, since libinput pulls in gtk+ which
> > adds roughly 400MiB.
> 
> Good catch; applied, thanks!
> 
> It never occurred to me that it could depend on GTK+; apparently that’s
> for some debugging GUI, but it’s not clear how it’s supposed to get
> invoked:
> 
> [...]
> 
> What’s is it used for?

FWIW, it has a man page:
<https://man.archlinux.org/man/extra/libinput/libinput-debug-gui.1.en>?

I did some quick searches for 'libinput-debug-gui' on the Web but
didn't find any uses in the wild, so maybe we don't really lose
anything by disabling it?

Also, having multiple library variants is a bit messy (there was some
bug involving multiple versions of cairo used by a single app?), so I'd
prefer to eliminate the libinput / libinput-minimal distinction (maybe
with a separate libinput-debug-gui package if desired?).

Greetings,
Maxime.
Ludovic Courtès June 24, 2022, 3:10 p.m. UTC | #3
Hi,

Maxime Devos <maximedevos@telenet.be> skribis:

> FWIW, it has a man page:
> <https://man.archlinux.org/man/extra/libinput/libinput-debug-gui.1.en>?

Since it’s under libexec/, I’d assume that it’s not meant to be invoked
directly, but the man page suggests otherwise?…

> I did some quick searches for 'libinput-debug-gui' on the Web but
> didn't find any uses in the wild, so maybe we don't really lose
> anything by disabling it?

Looks like it.

> Also, having multiple library variants is a bit messy (there was some
> bug involving multiple versions of cairo used by a single app?), so I'd
> prefer to eliminate the libinput / libinput-minimal distinction (maybe
> with a separate libinput-debug-gui package if desired?).

Yeah, maybe we can do that (with a comment), and apparently that’s even
an OK change for master.

If you provide a patch, I’ll happily apply it.  :-)

Ludo’.
Josselin Poiret June 26, 2022, 10:14 a.m. UTC | #4
Hi Ludo and Maxime, 

Ludovic Courtès <ludo@gnu.org> writes:
> Since it’s under libexec/, I’d assume that it’s not meant to be invoked
> directly, but the man page suggests otherwise?…

Just as a heads-up, the debug GUI is supposed to be launched through
`libinput debug-gui`.  I'm not sure there's anything there that cannot
be debugged through `libinput debug-envents` though.

Cheers,