mbox series

[bug#53818,v3,0/7] Add Repology updater

Message ID cover.1644412701.git.public@yoctocell.xyz
Headers show
Series Add Repology updater | expand

Message

Xinglu Chen Feb. 9, 2022, 1:22 p.m. UTC
Changes since v2:

* Change ‘#:cached?’ argument to ‘#:http-fetch’.

* Invalidate cache in tests and make sure the requested URL is the one
  we expect.

* Expound a bit on the documentation in the manual.

* Some more rules for guessing the Repology name of a package.

Xinglu Chen (7):
  upstream: Sort list of updaters.
  http-client: Make 'http-fetch/cached' take '#:headers' argument.
  http-client: 'http-fetch/cached' accepts a string or a <uri>.
  import: json: Make 'json-fetch' take '#:http-fetch' argument.
  import: Add 'repology' updater.
  gnu: xorg-server-xwayland: Set 'repology-name' property.
  gnu: xorg-server-xwayland: Prepare for cross-compilation.

 Makefile.am               |   3 +
 doc/guix.texi             |   8 ++
 gnu/packages/xorg.scm     |   8 +-
 guix/http-client.scm      |  18 ++-
 guix/import/json.scm      |   9 +-
 guix/import/repology.scm  | 249 ++++++++++++++++++++++++++++++++++++++
 guix/upstream.scm         |  29 ++++-
 tests/import-repology.scm | 150 +++++++++++++++++++++++
 8 files changed, 457 insertions(+), 17 deletions(-)
 create mode 100644 guix/import/repology.scm
 create mode 100644 tests/import-repology.scm


base-commit: ad9cd004c81a01e33a605221a102f4d20abe442d