mbox series

[bug#53895,0/5] More CPU detection

Message ID cover.1644401681.git.efraim@flashner.co.il
Headers show
Series More CPU detection | expand

Message

Efraim Flashner Feb. 9, 2022, 10:16 a.m. UTC
I noticed that my AMD CPU was showing up as bonnell, which was clearly
wrong. I ended up rewriting parts of the x86_64 section (and considered
having it also serve for i686) and then tried to add some bits for
aarch64. IMO it's worth having the compiler-cpu-architectures for
aarch64/armhf, at least until (guix transformations) is taught that for
aarch64/armhf to use -mtune in place of -march.

Efraim Flashner (5):
  guix: cpu: Rewrite based on feature flags.
  gnu: cpu: Add detection for AMD CPUs.
  gnu: gcc: Add compiler-cpu-architectures for aarch64.
  gnu: gcc: Add compiler-cpu-architectures for armhf.
  WIP: guix: cpu: Add detection for aarch64 CPUs.

 gnu/packages/gcc.scm |  33 +++++++-
 guix/cpu.scm         | 186 +++++++++++++++++++++++++++++++++++--------
 2 files changed, 186 insertions(+), 33 deletions(-)


base-commit: 71438cd4222a02b1f89152437c1ea20499baa6a2