mbox series

[bug#51581,0/2] Wrap lines in the description of generated packages

Message ID cover.1635891637.git.public@yoctocell.xyz
Headers show
Series Wrap lines in the description of generated packages | expand

Message

Xinglu Chen Nov. 3, 2021, 10:17 a.m. UTC
This series adds a ‘wrap-lines’ procedure which wraps the line in a
string, similar to ‘fill-paragraph’ in Emacs.  This is used to chop the
description of imported packages into multiple lines, instead of just
having one really long line.

Before:

--8<---------------cut here---------------start------------->8---
(description
    "Hakyll is a static website compiler library. It provides you with the tools to create a simple or advanced static website using a Haskell DSL and formats such as markdown or RST. You can find more information, including a tutorial, on the website: . * <http://jaspervdj.be/hakyll> . If you seek assistance, there's: . * A google group: <http://groups.google.com/group/hakyll> . * An IRC channel, @#hakyll@ on irc.libera.chat (we *do not* have a channel on Freenode anymore) . Additionally, there's the Haddock documentation in the different modules, meant as a reference.")
--8<---------------cut here---------------end--------------->8---

After:

--8<---------------cut here---------------start------------->8---
(description
    "Hakyll is a static website compiler library. It provides you with the tools to
create a simple or advanced static website using a Haskell DSL and formats such
as markdown or RST. You can find more information, including a tutorial, on the
website: . * <http://jaspervdj.be/hakyll> . If you seek assistance, there's: . *
A google group: <http://groups.google.com/group/hakyll> . * An IRC channel,
@#hakyll@ on irc.libera.chat (we *do not* have a channel on Freenode anymore) .
Additionally, there's the Haddock documentation in the different modules, meant as
a reference.")
--8<---------------cut here---------------end--------------->8---


Xinglu Chen (2):
  import: utils: Add ‘wrap-lines’ procedure.
  import: Beautify descriptions when appropriate.

 guix/import/elpa.scm     |  2 +-
 guix/import/gnu.scm      |  3 ++-
 guix/import/hackage.scm  |  4 ++--
 guix/import/minetest.scm |  2 +-
 guix/import/opam.scm     |  3 ++-
 guix/import/pypi.scm     |  2 +-
 guix/import/utils.scm    | 36 +++++++++++++++++++++++++++++++-----
 tests/import-utils.scm   |  5 +++++
 8 files changed, 45 insertions(+), 12 deletions(-)


base-commit: 0e19713c1fbfd3a01347e0d490434a53a596ed3c

Comments

Ludovic Courtès Nov. 12, 2021, 10:44 p.m. UTC | #1
Hi!

Xinglu Chen <public@yoctocell.xyz> skribis:

> This series adds a ‘wrap-lines’ procedure which wraps the line in a
> string, similar to ‘fill-paragraph’ in Emacs.  This is used to chop the
> description of imported packages into multiple lines, instead of just
> having one really long line.

Does (@ (guix ui) fill-paragraph) suit your needs?  :-)

If so, could you send updated patches?  The rest LGTM.

Thanks,
Ludo’.
Ludovic Courtès Dec. 1, 2021, 3:32 p.m. UTC | #2
Ping!  :-)

Ludovic Courtès <ludo@gnu.org> skribis:

> Hi!
>
> Xinglu Chen <public@yoctocell.xyz> skribis:
>
>> This series adds a ‘wrap-lines’ procedure which wraps the line in a
>> string, similar to ‘fill-paragraph’ in Emacs.  This is used to chop the
>> description of imported packages into multiple lines, instead of just
>> having one really long line.
>
> Does (@ (guix ui) fill-paragraph) suit your needs?  :-)
>
> If so, could you send updated patches?  The rest LGTM.
>
> Thanks,
> Ludo’.
Ludovic Courtès Dec. 17, 2021, 3:53 p.m. UTC | #3
Hi,

Xinglu Chen <public@yoctocell.xyz> skribis:

>   import: utils: Wrap files in description.
>   import: Beautify descriptions when appropriate.

Applied, thanks!

Ludo’.