mbox series

[bug#50873,0/7] Fixes to ‘guix home import’

Message ID cover.1633861021.git.public@yoctocell.xyz
Headers show
Series Fixes to ‘guix home import’ | expand

Message

Xinglu Chen Oct. 10, 2021, 10:19 a.m. UTC
Change since v1:

* Remove uses of ‘slurp-file-gexp’.

* Add tests for the Scheme API of (guix scripts home import).

Xinglu Chen (7):
  guix home: import: Make the user to specify a destination directory.
  guix home: import: Allow multiple modules to be imported for each
    service.
  guix home: import: Fix module name for Bash service.
  guix home: import: Don’t use 'slurp-file-gexp'.
  guix home: import: Delete duplicate modules when importing.
  doc: Document the ‘guix home import’ subcommand.
  Add tests for ‘guix home import’.

 Makefile.am                  |   1 +
 doc/guix.texi                |  32 +++++++
 guix/scripts/home.scm        |  25 +++--
 guix/scripts/home/import.scm | 115 +++++++++++++----------
 tests/home-import.scm        | 174 +++++++++++++++++++++++++++++++++++
 5 files changed, 289 insertions(+), 58 deletions(-)
 create mode 100644 tests/home-import.scm


base-commit: edbcbdabac9a64dba3850b0f7e596b396f044599

Comments

Xinglu Chen Oct. 30, 2021, 10:42 a.m. UTC | #1
Changes since v2:

* Call ‘local-file’ with a ‘name’ argument to make the /gnu/store/… file
  name more readable.

* Import some missing modules.

* Remove the ‘%destination-directory’ parameter, and instead pass the
  directory to ‘generate-bash-configuration+modules’.

* Other minor cleanups.

Xinglu Chen (8):
  guix home: import: Make the user to specify a destination directory.
  guix home: import: Allow multiple modules to be imported for each
    service.
  guix home: import: Fix module name for Bash service.
  guix home: import: Don’t use 'slurp-file-gexp'.
  guix home: import: Delete duplicate modules when importing.
  doc: Document the ‘guix home import’ subcommand.
  Add tests for ‘guix home import’.
  guix home: import: Call ‘local-file’ with ‘name’ argument.

 Makefile.am                  |   1 +
 doc/guix.texi                |  32 +++++++
 guix/scripts/home.scm        |  24 +++--
 guix/scripts/home/import.scm | 137 ++++++++++++++++----------
 tests/home-import.scm        | 180 +++++++++++++++++++++++++++++++++++
 5 files changed, 313 insertions(+), 61 deletions(-)
 create mode 100644 tests/home-import.scm


base-commit: c6adc0947396daa6d85ab08837f9cbc86f4d8722