mbox series

[bug#49531,core-updates,0/4] import: {utils, go, crate}: Emit new-style package inputs.

Message ID cover.1626067919.git.iskarian@mgsn.dev
Headers show
Series import: {utils, go, crate}: Emit new-style package inputs. | expand

Message

Sarah Morgensen July 12, 2021, 5:35 a.m. UTC
Hello Guix,

This should bring the go and crate importers into the new input-label-less
world (they both use PACKAGE-NAMES->PACKAGE-INPUTS in import/utils.scm). Cargo
build system is correspondingly updated to accept both new- and old-style
package inputs. I successfully tested importing, building, and running
'drill', a cargo-build-system package.

I think this leaves the hackage/stackage, egg, gem, and opam importers. Should
we open a bug to track them?

--
Sarah Morgensen (4):
  import: utils: Emit new-style package inputs.
  import: go: Emit new-style package inputs.
  import: crate: Emit new-style package inputs.
  cargo-build-system: Accept new-style package inputs.

 guix/build-system/cargo.scm |  9 ++++++---
 guix/import/crate.scm       |  5 +++--
 guix/import/utils.scm       | 13 ++++++-------
 guix/packages.scm           |  2 ++
 tests/crate.scm             | 30 +++++++++++-------------------
 tests/go.scm                |  3 ++-
 6 files changed, 30 insertions(+), 32 deletions(-)


base-commit: 9b4c3c675c05870e5983c21ce4ff944e0b0bc2fa