mbox series

[bug#48999,v2,0/3] Import Haskell packages from the local filesystem

Message ID cover.1625399149.git.public@yoctocell.xyz
Headers show
Series Import Haskell packages from the local filesystem | expand

Message

Xinglu Chen July 4, 2021, 11:53 a.m. UTC
Changes since v1:

* Add ‘--path’ command line option for importing the package from the
  local filesystem.

* Add ‘git-repository?’ and ‘hg-repository?’ procedures for correctly
  setting the #:select? keyword (‘git-predicate’ or ‘hg-predicate’) for
  ‘local-file’.  Other VCS don’t have a ‘-predicate’ procedure, so I
  didn’t bother adding those.

Patch [1/3] hasn’t changed since v1.

Xinglu Chen (3):
  import: hackage: Accept local source for package.
  import: utils: Add predicates for checking VCS repositories.
  scripts: import: hackage: Add option to import package from local
    filesystem.

 guix/import/hackage.scm         | 43 +++++++++++++++++++++------------
 guix/import/utils.scm           | 15 ++++++++++++
 guix/scripts/import/hackage.scm | 43 +++++++++++++++++++++++++++------
 tests/hackage.scm               | 28 +++++++++++++++++++--
 4 files changed, 103 insertions(+), 26 deletions(-)


base-commit: b65af6ed9120234cf655e8e76317558cfbd02477