mbox series

[bug#49014,0/2] Add tlf

Message ID alpine.DEB.2.21.2106132357190.2109@marsh.hcoop.net
Headers show
Series Add tlf | expand

Message

Jack Hill June 14, 2021, 4:12 a.m. UTC
This series adds a package for Tlf, an amateur (ham) radio logging 
program. Some things to note:

Tlf depends on hamlib, which has `Requires.private: libusb-1.0` in its 
pkg-config file. Tlf fails to build if libusb is not present in its build 
environment. I saw two options for resolving this: 1) add libusb as an 
input for tlf or 2) propagate libusb from hamlib. I chose the latter, but 
I'm not sure if that's the right choice as hamlib also provides binaries, 
so folks might want to install it in their profiles in addition to using 
it as a library.

The released version of Tlf doesn't work with our packaged version of 
hamlib because hamlib made a breaking change in the name of one of their 
macros. I added a patch from newer Tlf commits that works around this by 
adding some indirection.

I tested that it builds reproducably on x86_64-linux, and that it builds 
emulated aarch64-linux and armhf-linux. I was happy to see, especially on 
armhf, that I didn't run into the problem that caused Debian to add a 
patch:

https://salsa.debian.org/debian-hamradio-team/tlf/-/blob/8a0cbff093ac8846aa73ff012668b55628056ef4/debian/patches/979377-test-cabrillo

Jack Hill (2):
   gnu: hamlib: Make libusb a propagated input.
   gnu: Add tlf.

  gnu/local.mk                                  |  1 +
  .../patches/tlf-support-hamlib-4.2+.patch     | 66 +++++++++++++++++++
  gnu/packages/radio.scm                        | 64 +++++++++++++++++-
  3 files changed, 130 insertions(+), 1 deletion(-)
  create mode 100644 gnu/packages/patches/tlf-support-hamlib-4.2+.patch