[bug#77681,0/6,emacs-team] Run emacs tests

Message ID CH3PR84MB34243B6EDA6E5961B5D5F9AAC5B42@CH3PR84MB3424.NAMPRD84.PROD.OUTLOOK.COM
Headers
Series Run emacs tests |

Message

Morgan Smith April 9, 2025, 6:54 p.m. UTC
  I got a couple changes here but probably the most important is running the
emacs test suite.

I did want to ask about emacs-xwidgets though.  Recent versions of xwidgets
(like the one we have packaged) does not play well with Emacs.  For more
information see: Bug#66068

I don't think this will be resolved anytime soon though.  Do we make a
deprecated package for emacs-xwidgets or just remove it?

Morgan Smith (6):
  gnu: emacs-next: Update to 31.0.50-1.9663c95.
  gnu: emacs-magit-popup: Skip tests.
  gnu: emacs-guix: Skip tests.
  gnu: emacs-stgit: Skip tests.
  doc: Emacs Packages: Remove outdated commentary on testing.
  gnu: emacs: Run tests.

 doc/contributing.texi                         |  9 +-
 gnu/local.mk                                  |  1 +
 gnu/packages/emacs-xyz.scm                    |  4 +-
 gnu/packages/emacs.scm                        | 97 +++++++++++++++++--
 .../emacs-next-disable-jit-compilation.patch  | 19 ++++
 gnu/packages/version-control.scm              |  1 +
 6 files changed, 115 insertions(+), 16 deletions(-)
 create mode 100644 gnu/packages/patches/emacs-next-disable-jit-compilation.patch


base-commit: ca30726285b6883a3b1fa89db64177460af69c42
  

Comments

Gabriel Santos April 9, 2025, 7:05 p.m. UTC | #1
Em 9 de abril de 2025 15:54:12 BRT, Morgan Smith <Morgan.J.Smith@outlook.com> escreveu:
>I got a couple changes here but probably the most important is running the
>emacs test suite.
>
>I did want to ask about emacs-xwidgets though.  Recent versions of xwidgets
>(like the one we have packaged) does not play well with Emacs.  For more
>information see: Bug#66068
>
>I don't think this will be resolved anytime soon though.  Do we make a
>deprecated package for emacs-xwidgets or just remove it?
>
>Morgan Smith (6):
>  gnu: emacs-next: Update to 31.0.50-1.9663c95.
>  gnu: emacs-magit-popup: Skip tests.
>  gnu: emacs-guix: Skip tests.
>  gnu: emacs-stgit: Skip tests.
>  doc: Emacs Packages: Remove outdated commentary on testing.
>  gnu: emacs: Run tests.
>
> doc/contributing.texi                         |  9 +-
> gnu/local.mk                                  |  1 +
> gnu/packages/emacs-xyz.scm                    |  4 +-
> gnu/packages/emacs.scm                        | 97 +++++++++++++++++--
> .../emacs-next-disable-jit-compilation.patch  | 19 ++++
> gnu/packages/version-control.scm              |  1 +
> 6 files changed, 115 insertions(+), 16 deletions(-)
> create mode 100644 gnu/packages/patches/emacs-next-disable-jit-compilation.patch
>
>
>base-commit: ca30726285b6883a3b1fa89db64177460af69c42

In #77225[1], I removed emacs(-next)-xwidgets entirely.

[1] <https://issues.guix.gnu.org/77225>
  
Nicolas Graves April 9, 2025, 9:09 p.m. UTC | #2
On 2025-04-09 14:54, Morgan Smith wrote:

> I got a couple changes here but probably the most important is running the
> emacs test suite.
>
> I did want to ask about emacs-xwidgets though.  Recent versions of xwidgets
> (like the one we have packaged) does not play well with Emacs.  For more
> information see: Bug#66068
>
> I don't think this will be resolved anytime soon though.  Do we make a
> deprecated package for emacs-xwidgets or just remove it?
>
> Morgan Smith (6):
>   gnu: emacs-next: Update to 31.0.50-1.9663c95.
>   gnu: emacs-magit-popup: Skip tests.
>   gnu: emacs-guix: Skip tests.
>   gnu: emacs-stgit: Skip tests.
>   doc: Emacs Packages: Remove outdated commentary on testing.
>   gnu: emacs: Run tests.

I recently resumed some development efforts on emacs-guix, and will
probably come back to it from time to time.  Do you have an intuitive
assessment about how bad the situation is on emacs-guix tests?

TY Morgan!
  
Morgan Smith April 9, 2025, 9:20 p.m. UTC | #3
Nicolas Graves <ngraves@ngraves.fr> writes:

> On 2025-04-09 14:54, Morgan Smith wrote:
>
> I recently resumed some development efforts on emacs-guix, and will
> probably come back to it from time to time.  Do you have an intuitive
> assessment about how bad the situation is on emacs-guix tests?
>
> TY Morgan!

I'd love to see some development there!

As for the tests, I believe they don't exist.  I get no results from
running these commands:

find . -iname '*test*'
grep -r '\Wert\W' # looking for ert tests