mbox series

[bug#69292,0/6] Prepare the database code for use in the daemon

Message ID 87h6i3lyph.fsf@cbaines.net
Headers show
Series Prepare the database code for use in the daemon | expand

Message

Christopher Baines Feb. 20, 2024, 7:20 p.m. UTC
These changes prepare the database module for use in a Guile
implementation of the guix-daemon.

There's quite a few procedures that need adding, but these changes just
adapt the existing functionality in to something that can be built on.


Christopher Baines (6):
  store: database: Remove call-with-savepoint and associated code.
  store: database: Remove with-statement and associated code.
  store: database: Inline SQL to where it's used.
  store: database: Stop finalizing prepared statements.
  store: database: Refactor sqlite-register.
  store: database: Rename a couple of procedures.

 .dir-locals.el          |   3 -
 guix/store/database.scm | 273 +++++++++++++++++-----------------------
 2 files changed, 112 insertions(+), 164 deletions(-)


base-commit: f4af19b037826cad90bbcfe400ad864f028cc7d8

Comments

Christopher Baines April 3, 2024, 5:36 p.m. UTC | #1
Christopher Baines <mail@cbaines.net> writes:

> These changes prepare the database module for use in a Guile
> implementation of the guix-daemon.
>
> There's quite a few procedures that need adding, but these changes just
> adapt the existing functionality in to something that can be built on.
>
>
> Christopher Baines (6):
>   store: database: Remove call-with-savepoint and associated code.
>   store: database: Remove with-statement and associated code.
>   store: database: Inline SQL to where it's used.
>   store: database: Stop finalizing prepared statements.
>   store: database: Refactor sqlite-register.
>   store: database: Rename a couple of procedures.
>
>  .dir-locals.el          |   3 -
>  guix/store/database.scm | 273 +++++++++++++++++-----------------------
>  2 files changed, 112 insertions(+), 164 deletions(-)

I've pushed these to master as c9cd16c630ccba655b93ff32fd9a99570b4f5373.

Chris