[bug#77542,python-team,00/38] Further patches on python-team.

Message ID 20250404190959.30444-1-ngraves@ngraves.fr
Headers
Series Further patches on python-team. |

Message

Nicolas Graves April 4, 2025, 7:06 p.m. UTC
  As usual. A few notes:
- clipper2 was added for cura IIRC, which requires it but isn't ready yet / requires more work.
- I couldn't test python-pytensor update because of build times, so it might still break.

Nicolas Graves (38):
  gnu: Add clipper2.
  gnu: labelme: Add missing native-inputs.
  gnu: scregseg: Add missing native-inputs.
  gnu: autokey: Add missing native-inputs.
  gnu: mageck: Add missing native-inputs.
  gnu: python-pytroch-geometric: Skip failing tests.
  gnu: Add string-view-lite.
  gnu: python-pytensor: Update to 2.30.1.
  gnu: python-vaex-core: Update to 4.17.1.
  gnu: Remove pybind11-2.3.
  gnu: python-property-cached: Fix build.
  gnu: python-attr: Update to 0.3.2.
  gnu: python-serpent: Update to 1.41.
  gnu: python-pyro4: Update to 4.82.
  gnu: python-lcapy: Add missing native-inputs.
  gnu: python-linear-operator: Update to 0.6.
  gnu: gpytorch: Remove uneeded inputs.
  gnu: python-botorch: Add missing native-inputs.
  gnu: python-gpytorch: Update to 1.14.
  gnu: python-botorch: Update to 0.13.0.
  gnu: python-pgmpy: Update to 1.0.0.
  gnu: python-qasync: Ignore failing test.
  gnu: python-bed-reader: Fix build and enable tests.
  gnu: python-pysnptools: Fix build and enable tests.
  gnu: Add python-poetry-core-next.
  gnu: python-duniterpy: Update to 1.2.1.
  gnu: python-pgpy: Fix tests.
  gnu: python-furl: Update to 2.1.4.
  gnu: python-rq: Update to 2.3.1.
  gnu: python-crontab: Update to 3.2.0.
  gnu: python-stone: Update to 3.3.9.
  gnu: python-rq-scheduler: Update to 0.14.
  gnu: python-port-for: Update to 0.7.4.
  gnu: Remove python-cookies.
  gnu: python-django-rq: Update to 3.0.0.
  gnu: python-flask-seasurf: Update to 2.0.0.
  gnu: python-country-converter: Add missing native-input.
  gnu: python-itemloaders: Update to 1.3.2.

 gnu/local.mk                                  |   3 +
 gnu/packages/bioinformatics.scm               | 280 ++++++++++++++----
 gnu/packages/cpp.scm                          |  56 +++-
 gnu/packages/databases.scm                    |  67 +++--
 gnu/packages/django.scm                       |  28 +-
 gnu/packages/engineering.scm                  |   4 +-
 gnu/packages/finance.scm                      |  40 +--
 gnu/packages/image-processing.scm             |   3 +-
 gnu/packages/iso-codes.scm                    |   3 +-
 gnu/packages/machine-learning.scm             |  56 ++--
 .../python-bed-reader-use-store-samples.patch | 147 +++++++++
 .../python-property-cached-asyncio-3_11.patch | 201 +++++++++++++
 .../python-vaex-core-fix-tsl-use.patch        |  67 +++++
 gnu/packages/python-build.scm                 |  10 +
 gnu/packages/python-crypto.scm                |  15 +-
 gnu/packages/python-science.scm               |  87 +++---
 gnu/packages/python-web.scm                   |  60 ++--
 gnu/packages/python-xyz.scm                   | 186 ++++++------
 gnu/packages/statistics.scm                   |  16 +-
 19 files changed, 987 insertions(+), 342 deletions(-)
 create mode 100644 gnu/packages/patches/python-bed-reader-use-store-samples.patch
 create mode 100644 gnu/packages/patches/python-property-cached-asyncio-3_11.patch
 create mode 100644 gnu/packages/patches/python-vaex-core-fix-tsl-use.patch