[bug#77404,0/1] PETSc compiler optimization: Pass from -O1 to -O3

Message ID 20250331104217.825384-1-luca.cirrottola@inria.fr
Headers
Series PETSc compiler optimization: Pass from -O1 to -O3 |

Message

Luca Cirrottola March 31, 2025, 10:42 a.m. UTC
  Hello Guix,

I have recently noticed that the "petsc" package raises the following warnings during the configuration phase, showing that the compiler only does O1 optimization for now:

=============================================================================================
                         Configuring PETSc to compile on your system
=============================================================================================
=============================================================================================
                                     ***** WARNING *****
  Using default C optimization flags "-g -O". You might consider manually setting optimal
  optimization flags for your system with COPTFLAGS="optimization flags" see
  config/examples/arch-*-opt.py for examples
=============================================================================================
=============================================================================================
                                     ***** WARNING *****
  Using default Cxx optimization flags "-g". You might consider manually setting optimal
  optimization flags for your system with CXXOPTFLAGS="optimization flags" see
  config/examples/arch-*-opt.py for examples
=============================================================================================
=============================================================================================
                                     ***** WARNING *****
  Using default FC optimization flags "-g -O". You might consider manually setting optimal
  optimization flags for your system with FOPTFLAGS="optimization flags" see
  config/examples/arch-*-opt.py for examples
=============================================================================================

So here is a patch that follows the hints and passes the "-g -O3" flags to the COPTFLAGS, CXXOPTFLAGS and FOPTFLAGS variables.
The package builds successfully on my machine. Some tests fail for both the packages "petsc" and "petsc-openmpi", but these were failing already with the "-O1" flag (so maybe this could be the topic of another issue).
I am looking forward for your review.

Cheers,
Luca

Luca Cirrottola (1):
  Activate higher compiler optimization for PETSc.

 gnu/packages/maths.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)


base-commit: 4b97ae180fc13f7e4818cf48519f8a77c22c7797
  

Comments

Andreas Enge March 31, 2025, 2:06 p.m. UTC | #1
Hello,

thanks for the patch! I have pushed it after adapting the commit message
to our coding standards.

Andreas