[bug#77231,javascript-team,0/6] Improve importer and build-system.

Message ID 20250324071954.16997-1-ngraves@ngraves.fr
Headers
Series Improve importer and build-system. |

Message

Nicolas Graves March 24, 2025, 7:18 a.m. UTC
  Like in python, there are some development dependencies we want to
avoid since they are not contributing to the build at all.  This patch
series adds options to ignore them.

This change requires to rebuild node, so I prefer to do that on CI.

Nicolas Graves (6):
  import: npm-binary: Fix import.
  import: npm-binary: Improve npm-package->package-sexp.
  import: npm-binary: Improve-style.
  build-system/node: Add phase 'delete-unwanted-dev-dependencies.
  import: npm-binary: Handle vector of licenses.
  import: npm-binary: Filter out npm-ignored-inputs.

 guix/build/node-build-system.scm |  39 +++++++-
 guix/import/npm-binary.scm       | 160 ++++++++++++++++++-------------
 tests/npm-binary.scm             | 157 +++++++++++++++++-------------
 3 files changed, 215 insertions(+), 141 deletions(-)