[bug#77040,v2,00/20] Add pay-respects.

Message ID 20250315233915.744-1-gabrielsantosdesouza@disroot.org
Headers
Series Add pay-respects. |

Message

Gabriel Santos March 15, 2025, 11:28 p.m. UTC
  Greetings,

This is my first contibution to GNU Guix.

I should've mentioned this in my first version, but didn't because I
thought that everything had gone smoothly.

* Updates

I updated some of the packages. Though, due to the logic of semver[1],
I think that updating them won't result in any issues, but I'll build
some dependents to test this out.

Now, aside from the commits clearly defined as updates on their commit
messages, I also "updated" some other existing packages when adding a
new version, by making them derive from the new version I added. The
earliest example in my commits was rust-pulldown-cmark-0.13, please
check its commit message out to let me know about any mistakes I made.

* Backtrace

This patch isn't finished yet, due to the following backtrace:

$ ./pre-inst-env guix build pay-respects --keep-failed --log-file
Backtrace:
In ice-9/boot-9.scm:
  1752:10 19 (with-exception-handler _ _ #:unwind? _ # _)
In guix/ui.scm:
    491:6 18 (_)
In guix/scripts/build.scm:
    822:5 17 (_)
In srfi/srfi-1.scm:
   673:15 16 (append-map #<procedure 7fe8d4066050 at guix/scripts/b…> …)
   586:17 15 (map1 ("x86_64-linux"))
In guix/scripts/build.scm:
   824:21 14 (_ _)
In guix/store.scm:
  1413:11 13 (map/accumulate-builds #<store-connection 256.100 7fe8…> …)
   1331:8 12 (call-with-build-handler #<procedure 7fe8d654af00 at g…> …)
In guix/scripts/build.scm:
   778:16 11 (_ #<package pay-respects@0.6.14 gnu/packages/rust-apps…>)
   767:24 10 (_ #<package pay-respects@0.6.14 gnu/packages/rust-app…> …)
In guix/packages.scm:
  1444:17  9 (supported-package? #<package pay-respects@0.6.14 gnu/…> …)
In guix/memoization.scm:
    101:0  8 (_ #<hash-table 7fe8d42c5f20 0/31> #<package pay-respe…> …)
In guix/packages.scm:
  1422:39  7 (_)
  1692:16  6 (package->bag _ _ _ #:graft? _)
  1789:22  5 (thunk)
In guix/build-system/cargo.scm:
    218:2  4 (lower "pay-respects-0.6.14" #:source _ #:inputs _ # _ . #)
    219:4  3 (_ #:cargo-inputs _)
In ice-9/boot-9.scm:
  1685:16  2 (raise-exception _ #:continuable? _)
  1685:16  1 (raise-exception _ #:continuable? _)
  1685:16  0 (raise-exception _ #:continuable? _)

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
Invalid keyword: quasiquote

I don't think this should be happening, as most packages in
rust-apps use quasiquotes.

* References

[1] <https://semver.org/>

Gabriel Santos (20):
  gnu: rust-serde-derive-1: Update to 1.0.219.
  gnu: rust-serde-1: Update to 1.0.219.
  gnu: rust-clap-builder-4: Update to 4.5.32.
  gnu: rust-anstyle-1: Update to 1.0.10.
  gnu: Add rust-pulldown-cmark-0.13.
  gnu: rust-clap-derive-4: Update to 4.5.32.
  gnu: rust-clap-4: Update to 4.5.32.
  gnu: Add rust-insta-1.42.
  gnu: Add rust-colored-3.
  gnu: Add rust-base62-2.
  gnu: Add rust-libyml-0.0.5.
  gnu: Add rust-serde-yml-0.0.12.
  gnu: Add rust-siphasher-1.
  gnu: Add rust-rust-i18n-support-3.
  gnu: Add rust-rust-i18n-macro-3.
  gnu: Add rust-rust-i18n-3.
  gnu: Add rust-pay-respects-parser-0.3.
  gnu: Add rust-itertools-0.14.
  gnu: Add rust-pay-respects-utils-0.1.
  gnu: Add pay-respects.

 gnu/packages/crates-io.scm    | 366 +++++++++++++++++++++++++++++-----
 gnu/packages/crates-shell.scm |  47 +++++
 gnu/packages/rust-apps.scm    |  30 +++
 3 files changed, 394 insertions(+), 49 deletions(-)