[bug#76474,Cuirass,0/6] Add event logging actor.

Message ID 20250221153551.22658-1-romain.garbage@inria.fr
Headers
Series Add event logging actor. |

Message

Romain GARBAGE Feb. 21, 2025, 3:32 p.m. UTC
  This patch series aims at providing a new event logging actor. This will
be useful when integrating a mechanism that would notify forges such as
Forgejo or Gitlab about various events for example.

Ludovic Courtès (1):
  base: ‘remote-builder’ listens for notifications from ‘cuirass
    remote-server’.

Romain GARBAGE (5):
  utils: Add ring buffer implementation.
  base: Add event-log agent.
  register: Add support for event logging in builders.
  register: Add support for event logging in the jobset evaluator.
  register: Add support for event logging in the jobset registry.

 src/cuirass/base.scm                  | 160 +++++++++++++++++++++++---
 src/cuirass/scripts/register.scm      |   9 +-
 src/cuirass/scripts/remote-server.scm |  96 +++++++++++-----
 src/cuirass/utils.scm                 |  67 ++++++++++-
 tests/base.scm                        |  46 ++++++++
 tests/remote.scm                      |  47 ++++++--
 tests/utils.scm                       |  17 +++
 7 files changed, 385 insertions(+), 57 deletions(-)


base-commit: b6c2e340b24c4ea9701eb687669a091027bd361e
  

Comments

Ludovic Courtès Feb. 24, 2025, 5:40 p.m. UTC | #1
Romain GARBAGE <romain.garbage@inria.fr> skribis:

> This patch series aims at providing a new event logging actor. This will
> be useful when integrating a mechanism that would notify forges such as
> Forgejo or Gitlab about various events for example.

Pushed as 520b2fdbd96e953fc2d4b56e78e52a81fc11e2b7.

Note that I had to tweak ‘tests/remote.scm’ in the first commit
(b7a53d8872854b306656648f46f3df607bd0d15f) to ensure
‘start-notification-server’ would only return after said server is
actually listening on its Unix-domain socket.

Thanks for the nice work!

Ludo’.