mbox series

[bug#73927,v3,00/17] Installer support for (cross) installing the Hurd.

Message ID 20241025094011.8540-1-janneke@gnu.org
Headers show
Series Installer support for (cross) installing the Hurd. | expand

Message

Janneke Nieuwenhuizen Oct. 25, 2024, 9:39 a.m. UTC
New in this series:

  * guix install now creates essential devices for the Hurd
  * by default, no EFI partition is created
  * the grub configuration for the HURD now caters for non-HURD-VM (chilhurds)
  * make check-system TESTS="gui-installed-os now also works for non-x86

which makes that besides creating a sensible config.scm, the installed Hurd
now has a good chance to actually boot :)

Also updated hurd-team.

Greetings,
Janneke

Janneke Nieuwenhuizen (17):
  gnu: guile-fibers: Fix cross-build for the Hurd.
  guix system: When installing the Hurd, create essential devices.
  bootloader: grub: Remove hardcoded partition number for the Hurd.
  system: hurd: Remove qemu networking from %base-services/hurd.
  system: hurd: Add swap-services to hurd-default-essential-services.
  gnu: hurd: Support second boot.
  hurd-boot: Support second boot.
  maint: Add installer dependencies to the manifest.
  installer: Remove unused (newt) imports.
  installer: Align comments.
  installer: Use "partitioning-page" consistently.
  installer: Fix file-name typos.
  installer: Use `%' for parameter %run-command-in-installer.
  installer: Add dry-run?
  installer: Add "Kernel" page to select the Hurd.
  installer: Add static-networking template.
  installer: Support dry-run from Guile via store.

 gnu/bootloader/grub.scm                 |  42 ++++-
 gnu/build/hurd-boot.scm                 |  21 ++-
 gnu/installer.scm                       | 206 ++++++++++++++++++------
 gnu/installer/final.scm                 |  10 +-
 gnu/installer/kernel.scm                |  41 +++++
 gnu/installer/newt.scm                  |  24 ++-
 gnu/installer/newt/ethernet.scm         |   1 -
 gnu/installer/newt/final.scm            |  20 ++-
 gnu/installer/newt/kernel.scm           |  45 ++++++
 gnu/installer/newt/keymap.scm           |   6 +-
 gnu/installer/newt/locale.scm           |   7 +-
 gnu/installer/newt/page.scm             |   7 +-
 gnu/installer/newt/parameters.scm       |   1 -
 gnu/installer/newt/partition.scm        |  10 +-
 gnu/installer/newt/services.scm         |  32 ++--
 gnu/installer/parted.scm                | 117 +++++++++-----
 gnu/installer/record.scm                |   8 +-
 gnu/installer/services.scm              |  68 ++++++--
 gnu/installer/steps.scm                 |  30 ++--
 gnu/installer/tests.scm                 |  11 ++
 gnu/installer/utils.scm                 |  17 +-
 gnu/local.mk                            |   3 +
 gnu/packages/guile-xyz.scm              |  11 +-
 gnu/packages/hurd.scm                   |   6 +-
 gnu/packages/patches/hurd-startup.patch |  82 ++++++++++
 gnu/services/base.scm                   |  20 ++-
 gnu/services/virtualization.scm         |   4 +-
 gnu/system.scm                          |  13 +-
 gnu/system/examples/bare-hurd.tmpl      |  10 +-
 gnu/system/hurd.scm                     |  26 +--
 gnu/system/images/hurd.scm              |   2 +-
 gnu/tests/install.scm                   |   6 +-
 guix/scripts/system.scm                 |   6 +-
 manifest.scm                            |   7 +-
 34 files changed, 724 insertions(+), 196 deletions(-)
 create mode 100644 gnu/installer/kernel.scm
 create mode 100644 gnu/installer/newt/kernel.scm
 create mode 100644 gnu/packages/patches/hurd-startup.patch


base-commit: 2394a7f5fbf60dd6adc0a870366adb57166b6d8b