mbox series

[bug#70570,0/2] Python: Ignore unwanted development inputs.

Message ID 20240425155529.30747-1-ngraves@ngraves.fr
Headers show
Series Python: Ignore unwanted development inputs. | expand

Message

Nicolas Graves April 25, 2024, 3:42 p.m. UTC
This patch series implements a way to robustly and with minimal burden on maintainers to remove some python packages that are often put in native inputs. This allows these packages to be removed almost seemlessly in most cases from native-inputs where they are of no use, enabling to cut down the dependent rebuilds upon update, and more easily update them and their real dependents.

It is for the python-team branch. It will be followed by a more consequential patch series upon the python-team branch to actually remove these unwanted developement inputs, but is send before for reviews.

The patch series handles :
- guix lint warnings against the inclusion of these packages
- guix import pypi will automatically not include them when read in the package result
- ignoring pytest arguments defined in pytest.ini or setup.cfg regarding those packages

The patch series doesn't handle:
- ignoring these packages when they are explicitely listed as required for installation (which means that sometimes a snippet or a patch are necessary, but this is not the general case).

Nicolas Graves (2):
  guix: import: pypi: Ignore pypi-ignored-inputs.
  guix: pyproject-build-system: Ignore unwanted pytest flags.

 guix/build/pyproject-build-system.scm | 88 ++++++++++++++++++++++++++-
 guix/import/pypi.scm                  | 20 +++++-
 guix/lint.scm                         | 11 ++--
 tests/pypi.scm                        |  3 +-
 4 files changed, 111 insertions(+), 11 deletions(-)