mbox series

[bug#68680,mumi,v4,0/4] Add a button to copy a message Message-ID to the clipboard.

Message ID 20240126171358.20291-1-maxim.cournoyer@gmail.com
Headers show
Series Add a button to copy a message Message-ID to the clipboard. | expand

Message

Maxim Cournoyer Jan. 26, 2024, 5:13 p.m. UTC
This series adds a new HTML element to each message header to easily
copy the Message-ID of a message into the clipboard.  It makes use of
the (already included) Pico CSS library for tooltips and some new
JavaScript event handler.  The motivation was to make it easier to
retrieve the Message-ID for passing it to the 'b4 shazam' command when
applying long patches series.

I've deployed it on Berlin, so anyone can try it already and provide feedback.

Changes in v4:
 - Set icon sizes via CSS instead of HTML, which improves layout

Changes in v3:
 - Allow using the new copy button via the keyboard
 - Register event handlers on all copy message-id buttons
 - Move download icon sizes to CSS to resolve warning in Firefox
 - Add guard inside download button event to ensure only one event
   runs at a time, avoiding tooltip getting stuck on 'Copied!'
 - Use a class name instead of a unique ID for the message-id buttons
 - Register handlers to every message-id buttons

Changes in v2:
 - Add timestamp to CSS and JavaScript file names to force reload

Maxim Cournoyer (4):
  README.org: Add new sections to help newcomers get started.
  .gitignore: Register mumi.xapian and signing-key files.
  Add .patman configuration file.
  html: Add a button to copy a Message-ID to the clipboard.

 .gitignore              |  2 ++
 .patman                 |  7 +++++
 README.org              | 24 +++++++++++++++++
 assets/js/mumi.js       | 59 ++++++++++++++++++++++++++++++++++++++++-
 assets/mumi.scss        | 31 +++++++++++++++++++---
 mumi/web/view/html.scm  | 24 ++++++++++++-----
 mumi/web/view/utils.scm | 40 +++++++++++++++++-----------
 7 files changed, 162 insertions(+), 25 deletions(-)
 create mode 100644 .patman


base-commit: 025fc600f1cb4c73042bf920aee3e07d5fb9c53a