mbox series

[bug#68680,mumi,0/3] Add a button to copy a message Message-ID to the clipboard.

Message ID 20240124021535.15946-1-maxim.cournoyer@gmail.com
Headers show
Series Add a button to copy a message Message-ID to the clipboard. | expand

Message

Maxim Cournoyer Jan. 24, 2024, 2:15 a.m. UTC
This series adds a new HTML element to each message header to easily
copy the Message-ID of a message into the clipboard.  It makes use of
the (already included) Pico CSS library for tooltips and some new
JavaScript event handler.  The motivation was to make it easier to
retrieve the Message-ID for passing it to the 'b4 shazam' command when
applying long patches series.


Maxim Cournoyer (3):
  README.org: Add new sections to help newcomers get started.
  .gitignore: Register mumi.xapian and signing-key files.
  html: Add a button to copy a Message-ID to the clipboard.

 .gitignore              |  2 ++
 README.org              | 24 ++++++++++++++++++++++
 assets/js/mumi.js       | 31 ++++++++++++++++++++++++++++-
 assets/mumi.scss        | 23 ++++++++++++++++++---
 mumi/web/view/html.scm  | 20 +++++++++++++++----
 mumi/web/view/utils.scm | 44 +++++++++++++++++++++++++++--------------
 6 files changed, 121 insertions(+), 23 deletions(-)


base-commit: 025fc600f1cb4c73042bf920aee3e07d5fb9c53a

Comments

Maxim Cournoyer Jan. 24, 2024, 2:29 a.m. UTC | #1
+CC Ricardo and Arun in case they'd like to take a peek.

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> This series adds a new HTML element to each message header to easily
> copy the Message-ID of a message into the clipboard.  It makes use of
> the (already included) Pico CSS library for tooltips and some new
> JavaScript event handler.  The motivation was to make it easier to
> retrieve the Message-ID for passing it to the 'b4 shazam' command when
> applying long patches series.
>
>
> Maxim Cournoyer (3):
>   README.org: Add new sections to help newcomers get started.
>   .gitignore: Register mumi.xapian and signing-key files.
>   html: Add a button to copy a Message-ID to the clipboard.
>
>  .gitignore              |  2 ++
>  README.org              | 24 ++++++++++++++++++++++
>  assets/js/mumi.js       | 31 ++++++++++++++++++++++++++++-
>  assets/mumi.scss        | 23 ++++++++++++++++++---
>  mumi/web/view/html.scm  | 20 +++++++++++++++----
>  mumi/web/view/utils.scm | 44 +++++++++++++++++++++++++++--------------
>  6 files changed, 121 insertions(+), 23 deletions(-)
>
>
> base-commit: 025fc600f1cb4c73042bf920aee3e07d5fb9c53a