mbox series

[bug#65911,0/4] gnu: Add liquidctl.

Message ID 20230913095341.12586-1-jean@foundationdevices.com
Headers show
Series gnu: Add liquidctl. | expand

Message

Jean-Pierre De Jesus DIAZ Sept. 13, 2023, 9:53 a.m. UTC
This patch series adds the liquidctl package, a tool to manage liquid
cooling hardware.

Adds the python-smbus dependency and also adds libusb-compat as a
back-end for python-pyusb while enabling tests and fixing a bug when
libusb initialization results in an error as it would try to use the
libusb library for the openusb back-end which would result in symbol
errors.

Jean-Pierre De Jesus DIAZ (4):
  gnu: Add python-smbus.
  gnu: python-pyusb: Use G-Expressions.
  gnu: python-pyusb: Add libusb-compat backend.
  gnu: Add liquidctl.

 gnu/packages/hardware.scm | 39 +++++++++++++++++++++++
 gnu/packages/libusb.scm   | 67 +++++++++++++++++++++++++++------------
 gnu/packages/linux.scm    | 24 ++++++++++++++
 3 files changed, 110 insertions(+), 20 deletions(-)


base-commit: d4645d5d25c9de0def9745c48a96504e500ec850