mbox series

[bug#64670,0/1] Fixing failing builds of openjdk on aarch64

Message ID 20230716203552.180767-1-t1m@phrogstar.de
Headers show
Series Fixing failing builds of openjdk on aarch64 | expand

Message

Tim Johann July 16, 2023, 8:35 p.m. UTC
When I wanted to install Clojure on my Raspberry Pis, I was stumped to see
that there was no installable version of openjdk available on aarch64.  Seeing
the build fail, I saw that this was a very simple issue fixed in openjdk11
(cf.: [1] and [2]).  So, I created a patch and applied it to openjdk9 and
openjdk10, after which I was able to build openjdk@9.181, openjdk@10.46, and
openjdk@11.0.17 successfully on one of my RPis.  I hope that subsequently all
versions of openjdk can be built on aarch64.

[1]  https://bugs.openjdk.org/browse/JDK-8237885
[2] https://hg.openjdk.org/jdk-updates/jdk11u/rev/15cc1c8a6371).

Tim Johann (1):
  gnu: openjdk: patches for aarch64 build (openjdk9|openjdk10).

 gnu/packages/java.scm                             |  6 ++++--
 .../openjdk-10-duplicate-using-declaration.patch  | 15 +++++++++++++++
 .../openjdk-9-duplicate-using-declaration.patch   | 15 +++++++++++++++
 3 files changed, 34 insertions(+), 2 deletions(-)
 create mode 100644 gnu/packages/patches/openjdk-10-duplicate-using-declaration.patch
 create mode 100644 gnu/packages/patches/openjdk-9-duplicate-using-declaration.patch


base-commit: 796c823a0d1d0aec9f4af908eca462e58e5675b5

Comments

Tim Johann July 17, 2023, 3:41 p.m. UTC | #1
Hello,

I just found a kinda duplicate of this from May 06:
<https://issues.guix.gnu.org/63327>

So, why isn't this already pushed?

I'll keep this one open until one of our patches is applied.


Cheers

Tim
Tim Johann Aug. 11, 2023, 10:56 a.m. UTC | #2
Hello again,

said issue is merged (<https://issues.guix.gnu.org/63327>) now.

Unfortunately, it does not affect openjdk10, since it uses a different file system organisation than the former version.

I already suggested this solution to bug#63069 (<https://issues.guix.gnu.org/63069>) where a fix along the lines of separate patch files was proposed as a better alternative to issue #63327.

Still keeping this open until a patch for openjdk10 has been merged, too, which I would love to see soon.

Cheers

Tim
Efraim Flashner Oct. 5, 2023, 7:26 a.m. UTC | #3
On Fri, Aug 11, 2023 at 12:56:30PM +0200, Tim Johann wrote:
> Hello again,
> 
> said issue is merged (<https://issues.guix.gnu.org/63327>) now.
> 
> Unfortunately, it does not affect openjdk10, since it uses a different file system organisation than the former version.
> 
> I already suggested this solution to bug#63069 (<https://issues.guix.gnu.org/63069>) where a fix along the lines of separate patch files was proposed as a better alternative to issue #63327.
> 
> Still keeping this open until a patch for openjdk10 has been merged, too, which I would love to see soon.

Sorry for this issue taking so long to get resolved. I've added a phase
for openjdk-10 that replaces the phase for openjdk-9 with one that uses
the updated path.  Openjdk-11 doesn't inherit from openjdk-10 so it
doesn't look like we need to override the phase there, and I didn't see
the duplicate line when I checked the source file.

I've added you as a co-author for the patch.
Tim Johann Oct. 5, 2023, 11:47 a.m. UTC | #4
Thanks, Efraim!