mbox series

[bug#62196,000/182] Add FPM, update Rails and other Ruby additions/updates

Message ID 20230315025946.14371-1-maxim.cournoyer@gmail.com
Headers show
Series Add FPM, update Rails and other Ruby additions/updates | expand

Message

Maxim Cournoyer March 15, 2023, 2:59 a.m. UTC
Hello Guix,

This series contains various Ruby updates and new packages.  Some noteworthy
changes:

1. Update Rubocop & friends
2. Update Rails and partially enable its test suite
3. Add fpm
4. Various other updates and required packages additions.


Maxim Cournoyer (182):
  gnu: Add ruby-cabin.
  gnu: Add ruby-clamp.
  gnu: Add ruby-stud.
  gnu: Add ruby-insist.
  gnu: ruby-standard: Update to 1.24.3.
  gnu: ruby-oedipus-lex: Update to 2.6.0.
  gnu: ruby-oedipus-lex: Fix indentation.
  gnu: ruby-parser: Update to 3.2.1.1.
  gnu: ruby-rubocop-ast: Update to 1.27.0.
  gnu: Add ruby-rubocop-rake-minimal.
  gnu: ruby-unicode-display-width: Update to 2.4.2.
  gnu: Add ruby-rubocop-capybara-minimal.
  gnu: ruby-rspec: Update to 3.12.0.
  gnu: ruby-rspec-core: Update to 3.12.1.
  gnu: ruby-rspec-support: Update to 3.12.0.
  gnu: ruby-given-core: Update to 3.8.2.
  gnu: ruby-rspec-mocks: Update to 3.12.4.
  gnu: ruby-rspec-expectations: Update to 3.12.2.
  gnu: ruby-rspec-given: Update to 3.8.2.
  gnu: ruby-rubocop-performance: Update to 1.16.0.
  gnu: Add ruby-simplecov-json-formatter.
  gnu: ruby-simplecov-html: Update to 0.12.3.
  gnu: ruby-simplecov: Update to 0.22.0.
  gnu: Add ruby-rubocop-capybara.
  gnu: ruby-rubocop-rspec: Update to 2.19.0 and inverse inheritance
    relationship.
  gnu: Add ruby-rubocop-rake.
  gnu: ruby-rubocop: Update to 1.48.1
  gnu: ruby-thor: Update to 1.2.1.
  gnu: Add ruby-minitest-power-assert.
  gnu: Add ruby-m.
  gnu: Add ruby-language-server-protocol.
  gnu: ruby-standard: Enable test suite.
  gnu: ruby-standard: Relax requirements.
  gnu: Add ruby-dotenv.
  gnu: Add ruby-minitest-retry.
  gnu: Add ruby-dalli.
  gnu: redis: Update to 7.0.9.
  gnu: redis: Use gexps and streamline.
  gnu: hiredis: Update to 1.1.0.
  gnu: Add ruby-hiredis.
  gnu: ruby-minitest-5.14: Update to 5.15.0.
  gnu: ruby-rake: Update to 13.0.6.
  gnu: Add ruby-cucumber-compatibility-kit.
  gnu: ruby-cucumber-messages: Update to 21.0.1.
  gnu: Remove ruby-protobuf-cucumber.
  gnu: ruby-cucumber-tag-expressions: Update to 5.0.1, fixing build.
  gnu: ruby-cucumber-core: Update to 11.1.0.
  gnu: ruby-cucumber-wire: Update to 6.2.1.
  gnu: ruby-cucumber-html-formatter: Update to 20.2.1.
  gnu: Add ruby-cucumber-ci-environment.
  gnu: ruby-cucumber-expressions: Update to 16.1.2.
  gnu: ruby-gherkin: Update to 26.0.3, fixing build.
  gnu: ruby-gherkin: Rename to ruby-cucumber-gherkin.
  gnu: ruby-cucumber: Update to 8.0.0.
  gnu: Remove ruby-cucumber-create-meta.
  gnu: Add ruby-rake-manifest.
  gnu: ruby-aruba: Update to 2.1.0.
  gnu: ruby-activesupport: Update to 7.0.4.3.
  gnu: ruby-railties: Update to 7.0.4.3.
  gnu: Add ruby-bcrypt.
  gnu: ruby-activemodel: Update to 7.0.4.3 and enable tests.
  gnu: ruby-activerecord: Update to 7.0.4.3 and enable tests.
  gnu: Add ruby-simplecov-lcov.
  gnu: ruby-actionview: Update to 7.0.4.3.
  gnu: Add ruby-delayed-job.
  gnu: Add ruby-minitest-proveit.
  gnu: ruby-zeitwerk: Update to 2.6.7.
  gnu: Add ruby-queue-classic.
  gnu: ruby-activejob: Update to 7.0.4.3 and enable tests.
  gnu: Add ruby-xpath.
  gnu: ruby-addressable: Update to 2.8.1.
  gnu: Add ruby-launchy.
  gnu: Add ruby-websocket.
  gnu: Add ruby-selenium-webdriver.
  gnu: ruby-puma: Build with SSL support.
  gnu: Add ruby-minitest-stub-const.
  gnu: ruby-rack: Update to 2.2.6.3.
  gnu: ruby-rack: Update home page URL.
  gnu: Add ruby-rack-next.
  gnu: Add ruby-rack-cache.
  gnu: ruby-rack-test: Update to 2.1.0.
  gnu: ruby-rack-test: Update home page.
  gnu: ruby-rack-test: Honor #:tests? argument.
  gnu: ruby-sinatra: Update to 3.0.5.
  gnu: ruby-webrick: Update to 1.8.1.
  gnu: Add ruby-rackup.
  gnu: Add ruby-vcr-expat.
  gnu: Add ruby-prettier-print.
  gnu: Add ruby-syntax-tree.
  gnu: Add ruby-subprocess.
  gnu: Add ruby-rake-compiler-dock.
  gnu: Add ruby-concurrent-ruby.
  gnu: ruby-concurrent: Replace with ruby-concurrent-ruby.
  gnu: Add ruby-concurrent-ruby-ext.
  gnu: Add ruby-concurrent-ruby-edge.
  gnu: Add ruby-sorbet-runtime.
  gnu: Add ruby-rdiscount.
  gnu: Add ruby-ruby2-keywords.
  gnu: Add ruby-faraday-net-http.
  gnu: ruby-faraday: Update to 2.7.4 and enable test suite.
  gnu: ruby-octokit: Update to 6.1.0.
  gnu: ruby-faraday: Propagate ruby-faraday-net-http.
  gnu: ruby-sawyer: Update to 0.9.2.
  gnu: ruby-pry-byebug: Avoid depending on ruby-chandler.
  gnu: ruby-pry-byebug: Update to 3.10.1.
  gnu: ruby-byebug: Do not depend on ruby-chandler.
  gnu: Remove ruby-chandler.
  gnu: Add ruby-multipart-parser.
  gnu: Add ruby-faraday-multipart.
  gnu: ruby-maxitest: Update to 4.4.1.
  gnu: Add ruby-fileutils.
  gnu: ruby-faraday-middleware: Add a deprecation comment and re-indent.
  gnu: ruby-bandwidth-iris: Fix indentation.
  gnu: ruby-bandwidth-iris: Update to 7.0.0.
  gnu: ruby-octokit: Enable tests.
  gnu: Add ruby-mapping.
  gnu: Add ruby-fiber-local.
  gnu: Add ruby-console.
  gnu: Add ruby-ruby-memcheck.
  gnu: Add ruby-msgpack.
  gnu: Add ruby-covered.
  gnu: Add ruby-samovar.
  gnu: Add ruby-io-console.
  gnu: Add ruby-reline.
  gnu: Add ruby-irb.
  gnu: Add ruby-debug.
  gnu: Add ruby-rspec-debug.
  gnu: Add ruby-bake.
  gnu: Add ruby-bake-test.
  gnu: Add ruby-bake-test-external.
  gnu: Add ruby-sus.
  gnu: Add ruby-timers.
  gnu: Add ruby-localhost.
  gnu: bundler: Update to 2.4.8.
  gnu: ruby-puma: Update to 6.1.1 and enable test suite.
  gnu: Add ruby-capybara.
  gnu: Add ruby-rack-session.
  gnu: ruby-rubyzip: Update to 2.3.2.
  gnu: ruby-actionpack: Update to 7.0.4.3 and enable test suite.
  gnu: Add ruby-event-emitter.
  gnu: Add ruby-websocket-native.
  gnu: Add ruby-websocket-eventmachine-base.
  gnu: Add ruby-websocket-eventmachine-server.
  gnu: Add ruby-websocket-client-simple.
  gnu: ruby-actioncable: Update to 7.0.4.3 and enable tests.
  gnu: ruby-mini-mime: Update to 1.1.2.
  gnu: ruby-marcel: Update to 1.0.2.
  gnu: ruby-marcel: Relocate to (gnu packages rails).
  gnu: ruby-marcel: Enable tests.
  gnu: ruby-activestorage: Update to 7.0.4.3.
  gnu: ruby-actiontext: Update to 7.0.4.3.
  gnu: Add ruby-timeout.
  gnu: Add ruby-net-protocol.
  gnu: Add ruby-date.
  gnu: Add ruby-net-imap.
  gnu: Add ruby-net-pop.
  gnu: Add ruby-net-smtp.
  gnu: ruby-actionmailbox: Update to 7.0.4.3.
  gnu: ruby-actionmailer: Update to 7.0.4.3.
  gnu: ruby-sprockets: Update to 4.2.0.
  gnu: ruby-sprockets: Relocate to (gnu packages rails).
  gnu: ruby-sprockets-rails: Update to 3.4.2.
  gnu: Add ruby-bootsnap.
  gnu: ruby-globalid: Update to 1.1.0.
  gnu: ruby-globalid: Move to (gnu packages rails).
  gnu: Add ruby-importmap-rails.
  gnu: ruby-railties: Enable test suite.
  gnu: Add ruby-propshaft.
  gnu: Add ruby-stimulus-rails.
  gnu: Add ruby-turbo-rails.
  gnu: ruby-rails: Update to 7.0.4.3.
  gnu: ruby-spring: Update to 4.1.1.
  gnu: Add ruby-dotenv-rails.
  gnu: Add ruby-flores.
  gnu: Add ruby-pleaserun.
  gnu: Add ruby-arr-pm.
  gnu: Add perl-app-cpanminus.
  gnu: ruby-minitest: Update home page URL.
  gnu: ruby-minitest: Update to 5.18.0.
  gnu: ruby-cucumber-html-formatter: Honor #:tests? argument.
  gnu: ruby-rubocop-rspec-minimal: Update source and home page URL.
  gnu: Add fpm.

 gnu/local.mk                                  |    1 +
 gnu/packages/databases.scm                    |  128 +-
 gnu/packages/package-management.scm           |   80 +
 .../ruby-hiredis-use-system-hiredis.patch     |   52 +
 gnu/packages/perl.scm                         |   21 +
 gnu/packages/protobuf.scm                     |   18 +-
 gnu/packages/rails.scm                        | 1210 ++++--
 gnu/packages/ruby.scm                         | 3774 +++++++++++++----
 8 files changed, 4161 insertions(+), 1123 deletions(-)
 create mode 100644 gnu/packages/patches/ruby-hiredis-use-system-hiredis.patch


base-commit: d37b467631d5b0e965ea933b8bda8448993580e9

Comments

Christopher Baines March 21, 2023, 7:50 a.m. UTC | #1
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hello Guix,
>
> This series contains various Ruby updates and new packages.  Some noteworthy
> changes:
>
> 1. Update Rubocop & friends
> 2. Update Rails and partially enable its test suite
> 3. Add fpm
> 4. Various other updates and required packages additions.

Thanks for looking at this Maxim.

Unfortunately Patchwork seems to have picked this up as 2 incomplete
series. If you had problems with git send-email, the --batch-size and
--relogin-delay options might help.

Anyway, would you be able to push a branch manually to
git.guix-patches.cbaines.net? It would need to be called issue-62196,
and ideally you'd push a tag (base-for-issue-62196) as well for the
commit on master the branch is based on. That should get
data.qa.guix.gnu.org to look at the changes, plus make it easier for me
to apply locally. I've given your ssh key from the maintenance.git
repository access, so you should be able to use that to push.

Thanks,

Chris
Maxim Cournoyer March 21, 2023, 4:03 p.m. UTC | #2
Hi!

Christopher Baines <mail@cbaines.net> writes:

> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
>> Hello Guix,
>>
>> This series contains various Ruby updates and new packages.  Some noteworthy
>> changes:
>>
>> 1. Update Rubocop & friends
>> 2. Update Rails and partially enable its test suite
>> 3. Add fpm
>> 4. Various other updates and required packages additions.
>
> Thanks for looking at this Maxim.
>
> Unfortunately Patchwork seems to have picked this up as 2 incomplete
> series. If you had problems with git send-email, the --batch-size and
> --relogin-delay options might help.

I had problems with Gmail interrupting the submission every 100 patches
sent.  I'll look into configuring these, thank you!

> Anyway, would you be able to push a branch manually to
> git.guix-patches.cbaines.net? It would need to be called issue-62196,
> and ideally you'd push a tag (base-for-issue-62196) as well for the
> commit on master the branch is based on. That should get
> data.qa.guix.gnu.org to look at the changes, plus make it easier for me
> to apply locally. I've given your ssh key from the maintenance.git
> repository access, so you should be able to use that to push.

I've just done so; let me know if something is amiss!
Maxim Cournoyer March 29, 2023, 2:48 a.m. UTC | #3
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hi!
>
> Christopher Baines <mail@cbaines.net> writes:
>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>
>>> Hello Guix,
>>>
>>> This series contains various Ruby updates and new packages.  Some noteworthy
>>> changes:
>>>
>>> 1. Update Rubocop & friends
>>> 2. Update Rails and partially enable its test suite
>>> 3. Add fpm
>>> 4. Various other updates and required packages additions.
>>
>> Thanks for looking at this Maxim.
>>
>> Unfortunately Patchwork seems to have picked this up as 2 incomplete
>> series. If you had problems with git send-email, the --batch-size and
>> --relogin-delay options might help.
>
> I had problems with Gmail interrupting the submission every 100 patches
> sent.  I'll look into configuring these, thank you!
>
>> Anyway, would you be able to push a branch manually to
>> git.guix-patches.cbaines.net? It would need to be called issue-62196,
>> and ideally you'd push a tag (base-for-issue-62196) as well for the
>> commit on master the branch is based on. That should get
>> data.qa.guix.gnu.org to look at the changes, plus make it easier for me
>> to apply locally. I've given your ssh key from the maintenance.git
>> repository access, so you should be able to use that to push.
>
> I've just done so; let me know if something is amiss!

Perhaps I should have been more patient for QA to build this, but I've
gone ahead and merged it to master (I had manually built everything), as
it was bit-rotting just by looking at it :-).