mbox series

[bug#61645,mumi,v3,0/4] Add mumi CLI client

Message ID 20230308153658.19929-1-arunisaac@systemreboot.net
Headers show
Series Add mumi CLI client | expand

Message

Arun Isaac March 8, 2023, 3:36 p.m. UTC
Here is a v3 of the patchset.

This patchset reduces the number of `git send-email' invocations to a
maximum of 2 even when there are n patches. The first patch is sent
using a `git send-email' invocation and the remaining n-1 patches are
sent using another `git send-email' invocation.

With this patchset, when sending a single patch, the mumi server is
not polled for the issue number since that's not necessary.

I also fixed a bug to do with printing the number of retries left.

Arun Isaac (4):
  client: Add CLI client to search for issues.
  client: Support checking in to a specific issue.
  client: Support sending email to issues.
  Set only GUILE_LOAD_PATH when running tests.

 Makefile.am      |   5 +-
 mumi/client.scm  | 264 +++++++++++++++++++++++++++++++++++++++++++++++
 scripts/mumi.in  |  33 +++++-
 tests/client.scm | 118 +++++++++++++++++++++
 4 files changed, 417 insertions(+), 3 deletions(-)
 create mode 100644 mumi/client.scm
 create mode 100644 tests/client.scm