mbox series

[bug#61645,mumi,0/1] Add CLI client to search for issues

Message ID 20230220013821.27440-1-arunisaac@systemreboot.net
Headers show
Series Add CLI client to search for issues | expand

Message

Arun Isaac Feb. 20, 2023, 1:38 a.m. UTC
Hi Ricardo,

This patch adds a mumi CLI client that lets one search for issues from
the command line by calling mumi's GraphQL API. This patch requires a
.mumi/config file in the guix repo with the following contents.

--8<---------------cut here---------------start------------->8---
((debbugs-host . "debbugs.gnu.org")
 (patch-email-address . "guix-patches@gnu.org")
 (mumi-host . "issues.guix.gnu.org"))
--8<---------------cut here---------------end--------------->8---

After adding .mumi/config, you can run search queries like

$ /path/to/mumi/pre-inst-env mumi search zig is:open

This is only the beginning. I have WIP patches that will add a "mumi
send-email" subcommand that will finally free us from our debbugs
dance when sending multiple patches. I will send them separately once
I have tested it more.

Regards,
Arun

Arun Isaac (1):
  client: Add CLI client to search for issues.

 Makefile.am     |   1 +
 mumi/client.scm | 108 ++++++++++++++++++++++++++++++++++++++++++++++++
 scripts/mumi.in |   8 +++-
 3 files changed, 116 insertions(+), 1 deletion(-)
 create mode 100644 mumi/client.scm

Comments

Ludovic Courtès March 8, 2023, 12:05 p.m. UTC | #1
Hi Arun,

Arun Isaac <arunisaac@systemreboot.net> skribis:

> This patch adds a mumi CLI client that lets one search for issues from
> the command line by calling mumi's GraphQL API. This patch requires a
> .mumi/config file in the guix repo with the following contents.
>
> ((debbugs-host . "debbugs.gnu.org")
>  (patch-email-address . "guix-patches@gnu.org")
>  (mumi-host . "issues.guix.gnu.org"))
>
> After adding .mumi/config, you can run search queries like
>
> $ /path/to/mumi/pre-inst-env mumi search zig is:open

Yay, this is great!!

> This is only the beginning. I have WIP patches that will add a "mumi
> send-email" subcommand that will finally free us from our debbugs
> dance when sending multiple patches. I will send them separately once
> I have tested it more.

Woow, sounds really nice.  I’m all for it!

Thanks,
Ludo’.
Arun Isaac March 8, 2023, 1:28 p.m. UTC | #2
>> This is only the beginning. I have WIP patches that will add a "mumi
>> send-email" subcommand that will finally free us from our debbugs
>> dance when sending multiple patches. I will send them separately once
>> I have tested it more.

I've already sent these patches as a v2 to this same issue. Waiting for
Ricardo to merge it now.

> Woow, sounds really nice.  I’m all for it!

Yep, it's going to be awesome! :-)
Ludovic Courtès March 30, 2023, 8:47 p.m. UTC | #3
Hello,

Arun Isaac <arunisaac@systemreboot.net> skribis:

>>> This is only the beginning. I have WIP patches that will add a "mumi
>>> send-email" subcommand that will finally free us from our debbugs
>>> dance when sending multiple patches. I will send them separately once
>>> I have tested it more.
>
> I've already sent these patches as a v2 to this same issue. Waiting for
> Ricardo to merge it now.

I suspect Ricardo is busy with other things.  :-)

Should we set up a repo on Savannah (possibly within the ‘guix’ project)
or on notabug.org, sr.ht, codeberg.org or whatever to make it easier to
distribute permissions?

Ludo’.
Ricardo Wurmus March 30, 2023, 8:57 p.m. UTC | #4
Ludovic Courtès <ludo@gnu.org> writes:

> Arun Isaac <arunisaac@systemreboot.net> skribis:
>
>>>> This is only the beginning. I have WIP patches that will add a "mumi
>>>> send-email" subcommand that will finally free us from our debbugs
>>>> dance when sending multiple patches. I will send them separately once
>>>> I have tested it more.
>>
>> I've already sent these patches as a v2 to this same issue. Waiting for
>> Ricardo to merge it now.
>
> I suspect Ricardo is busy with other things.  :-)

Oof, indeed!  Very sorry about that.

Arun, thank you for the patches!

I have applied the patches locally, but ever since I moved
git.elephly.net to gitile on the rockpro64 I haven’t been able to push
to my repos.  I hadn’t been able to make any time to diagnose this
problem as yet.  (Probably related to nginx rewrite rules.)

> Should we set up a repo on Savannah (possibly within the ‘guix’ project)
> or on notabug.org, sr.ht, codeberg.org or whatever to make it easier to
> distribute permissions?

Whichever you decide on: it has my blessing.
Ricardo Wurmus March 30, 2023, 9:57 p.m. UTC | #5
Ricardo Wurmus <rekado@elephly.net> writes:

> I have applied the patches locally, but ever since I moved
> git.elephly.net to gitile on the rockpro64 I haven’t been able to push
> to my repos.  I hadn’t been able to make any time to diagnose this
> problem as yet.  (Probably related to nginx rewrite rules.)

Fixed and pushed.
Ludovic Courtès March 31, 2023, 12:15 p.m. UTC | #6
Hi!

Ricardo Wurmus <rekado@elephly.net> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:

[...]

>> Should we set up a repo on Savannah (possibly within the ‘guix’ project)
>> or on notabug.org, sr.ht, codeberg.org or whatever to make it easier to
>> distribute permissions?
>
> Whichever you decide on: it has my blessing.

Awesome (I hope that suggestion didn’t come out as harsh!).

Arun, would you like to handle this?  :-)  To have it under the Guix
umbrella on Savannah, you need to file a “support request” on Savannah
asking for a new Git repo.  If you choose something else, well, it’s
different (I’d personally recommend against git{hub,lab}.com).

Ludo’.
Arun Isaac March 31, 2023, 8:32 p.m. UTC | #7
Hi Ludo and Ricardo,

> Arun, would you like to handle this?  :-)  To have it under the Guix
> umbrella on Savannah, you need to file a “support request” on Savannah
> asking for a new Git repo.

Done! See https://savannah.nongnu.org/support/?110861

> If you choose something else, well, it’s different (I’d personally
> recommend against git{hub,lab}.com).

Definitely! I am no big fan of git{hub,lab} either.

From time to time, I need to update the running instance of mumi on the
server and refresh the xapian index. So, it might also help if I could
have access to the server running mumi. Would it be appropriate for me
to have access?

Thanks!
Arun
Ludovic Courtès March 31, 2023, 10:15 p.m. UTC | #8
Hello!

Arun Isaac <arunisaac@systemreboot.net> skribis:

>> Arun, would you like to handle this?  :-)  To have it under the Guix
>> umbrella on Savannah, you need to file a “support request” on Savannah
>> asking for a new Git repo.
>
> Done! See https://savannah.nongnu.org/support/?110861

Yay!

>> If you choose something else, well, it’s different (I’d personally
>> recommend against git{hub,lab}.com).
>
> Definitely! I am no big fan of git{hub,lab} either.
>
> From time to time, I need to update the running instance of mumi on the
> server and refresh the xapian index. So, it might also help if I could
> have access to the server running mumi. Would it be appropriate for me
> to have access?

I think so!  Could you email guix-sysadmin@gnu.org so everyone involved
has a chance to see your request?

Thank you,
Ludo’.
Arun Isaac March 31, 2023, 10:51 p.m. UTC | #9
> I think so!  Could you email guix-sysadmin@gnu.org so everyone involved
> has a chance to see your request?

Done, thanks!
Arun Isaac April 1, 2023, 5:32 p.m. UTC | #10
Hi Ludo,

>>> Arun, would you like to handle this?  :-)  To have it under the Guix
>>> umbrella on Savannah, you need to file a “support request” on Savannah
>>> asking for a new Git repo.
>>
>> Done! See https://savannah.nongnu.org/support/?110861

They want an admin of the Guix project to confirm my request. Could you
please go to the support request page and do so?

Thanks!
Arun
Arun Isaac April 24, 2023, 2:41 p.m. UTC | #11
Hi,

I have pushed a copy of the mumi repo to Savannah and updated our mumi
package to the latest commit of mumi. I will send out a separate email
to guix-devel explaining how to use the new mumi client.

At some point in the near future, we should consider making a mumi 0.1.0
release.

Regards,
Arun
Ludovic Courtès April 24, 2023, 8:01 p.m. UTC | #12
Hi,

Arun Isaac <arunisaac@systemreboot.net> skribis:

> I have pushed a copy of the mumi repo to Savannah and updated our mumi
> package to the latest commit of mumi. I will send out a separate email
> to guix-devel explaining how to use the new mumi client.

Yay!

> At some point in the near future, we should consider making a mumi 0.1.0
> release.

Maybe consider 1.0, even?  After all, it does the job, right?

  https://0ver.org/

Ludo’.
Arun Isaac April 25, 2023, 12:28 p.m. UTC | #13
>> At some point in the near future, we should consider making a mumi 0.1.0
>> release.
>
> Maybe consider 1.0, even?  After all, it does the job, right?

Sure, 1.0.0 is good too!