mbox series

[bug#60410,0/7] mumi: Boolean prefixes in xapian indexing and others

Message ID 20221229201809.27997-1-arunisaac@systemreboot.net
Headers show
Series mumi: Boolean prefixes in xapian indexing and others | expand

Message

Arun Isaac Dec. 29, 2022, 8:18 p.m. UTC
Hi Ricardo,

This is a patchset that has been sleeping for some time in my local
git repo. So, I thought it was about time to send it over!

The main change is that some xapian prefixes should be indexed as
boolean prefixes. This makes the use of an implicit AND operator
unneccessary and lets xapian do the natural thing of ordering results
by relevance. I believe this improves the search significantly. Also,
since we retrieve search results by relevance, we can offload limiting
of search results to xapian. Thus, we improve performance as well.

For this patchset to be useful, mumi's xapian index will have to be
rebuilt. In general, it is good to periodically rebuilt the xapian
index from scratch.

Regards,
Arun

Arun Isaac (7):
  xapian: Index several terms as boolean and without positions.
  xapian: Declare some prefixes as boolean.
  xapian: Do not override the default OR implicit query operator.
  messages: Remove unused set intersection feature in search-bugs.
  messages: Offload limiting search results to xapian.
  cache: Specify that cache! returns the cached value.
  xapian: Preserve order of search results.

 mumi/cache.scm    |   3 +-
 mumi/messages.scm |  29 ++++--------
 mumi/xapian.scm   | 109 +++++++++++++++++++++++++++++++---------------
 3 files changed, 86 insertions(+), 55 deletions(-)